Fix build against xorg-server >= 1.20. Patch taken from upstream: https://cgit.freedesktop.org/xorg/driver/xf86-video-savage/commit/?id=0ece556daa8a88771b669d8104396abd9166d2d0 diff --git a/src/savage_driver.c b/src/savage_driver.c index 58a294d..3cda923 100644 --- a/src/savage_driver.c +++ b/src/savage_driver.c @@ -2034,8 +2034,6 @@ static Bool SavagePreInit(ScrnInfoPtr pScrn, int flags) xf86DrvMsg(pScrn->scrnIndex, X_PROBED, "Detected current MCLK value of %1.3f MHz\n", mclk / 1000.0); - pScrn->maxHValue = 2048 << 3; /* 11 bits of h_total 8-pixel units */ - pScrn->maxVValue = 2048; /* 11 bits of v_total */ pScrn->virtualX = pScrn->display->virtualX; pScrn->virtualY = pScrn->display->virtualY; @@ -3637,6 +3635,14 @@ static ModeStatus SavageValidMode(SCRN_ARG_TYPE arg, DisplayModePtr pMode, (pMode->VDisplay > psav->PanelY))) return MODE_PANEL; + /* 11 bits of h_total 8-pixel units */ + if (pMode->HTotal > (2048 << 3)) + return MODE_BAD_HVALUE; + + /* 11 bits of v_total */ + if (pMode->VTotal > 2048) + return MODE_BAD_VVALUE; + if (psav->UseBIOS) { refresh = SavageGetRefresh(pMode); return (SavageMatchBiosMode(pScrn,pMode->HDisplay, mples/beaglebone-black.tmpl'>logtreecommitdiff
path: root/gnu/system/examples/beaglebone-black.tmpl
> 53ea46d880e9a7'>snippets: tempel: Fix calls to mapconcat....
AgeCommit message (Expand)Author
2023-03-03services: base: Deprecate 'agetty-service' procedure....Bruno Victal
2022-12-16system: examples: Add mode prop line....Maxim Cournoyer
gnu: ccache: Upgrade to 3.3.1....Eric Bavier
2016-09-22gnu: ccache: Use modify-phases....Eric Bavier
2016-07-10gnu: ccache: Update to 3.2.5....Efraim Flashner
2016-02-01gnu: ccache: Update to 3.2.4....Eric Bavier
2015-07-14gnu: ccache: Update to 3.2.2....Eric Bavier
2014-10-20gnu: ccache: Upgrade to 3.1.10....Eric Bavier
2014-05-20gnu: Add ccache....Eric Bavier
Liliana Marie Prikler
2022-09-26etc: Add tempel snippet move....Nicolas Graves
2022-08-30etc: Update yasnippet build system list....Nicolas Graves
2022-08-30etc: Add tempel snippet for :phases....Nicolas Graves
2022-08-30etc: Add tempel snippets....Nicolas Graves