Fix build against xorg-server >= 1.20.
Patch taken from upstream:
https://cgit.freedesktop.org/xorg/driver/xf86-video-savage/commit/?id=0ece556daa8a88771b669d8104396abd9166d2d0
diff --git a/src/savage_driver.c b/src/savage_driver.c
index 58a294d..3cda923 100644
--- a/src/savage_driver.c
+++ b/src/savage_driver.c
@@ -2034,8 +2034,6 @@ static Bool SavagePreInit(ScrnInfoPtr pScrn, int flags)
xf86DrvMsg(pScrn->scrnIndex, X_PROBED, "Detected current MCLK value of %1.3f MHz\n",
mclk / 1000.0);
- pScrn->maxHValue = 2048 << 3; /* 11 bits of h_total 8-pixel units */
- pScrn->maxVValue = 2048; /* 11 bits of v_total */
pScrn->virtualX = pScrn->display->virtualX;
pScrn->virtualY = pScrn->display->virtualY;
@@ -3637,6 +3635,14 @@ static ModeStatus SavageValidMode(SCRN_ARG_TYPE arg, DisplayModePtr pMode,
(pMode->VDisplay > psav->PanelY)))
return MODE_PANEL;
+ /* 11 bits of h_total 8-pixel units */
+ if (pMode->HTotal > (2048 << 3))
+ return MODE_BAD_HVALUE;
+
+ /* 11 bits of v_total */
+ if (pMode->VTotal > 2048)
+ return MODE_BAD_VVALUE;
+
if (psav->UseBIOS) {
refresh = SavageGetRefresh(pMode);
return (SavageMatchBiosMode(pScrn,pMode->HDisplay,
=d8537c68d09daaa3e8db35022ac45b5f2fe8ffda'>treecommitdiff
|
Age | Commit message (Expand) | Author |
2022-08-05 | doc: Fix Guix manual URLs in 'htmlxref.cnf'....Fixes a regression introduced in
868da34d54365023223a4ff7520043ba55ad64e8.
* doc/htmlxref.cnf (GUIX): Remove "/guix".
| Ludovic Courtès |
2022-06-16 | doc: Remove obsolete comment from htmlxref.cnf....This is follow up to <https://issues.guix.gnu.org/55290>.
* doc/htmlxref.cnf (geiser): Delete obsolete comment.
| Maxim Cournoyer |
2022-04-08 | doc: Fix cookbook URLs in htmlxref.cnf....Reported by Greg Hogan <code@greghogan.com>.
* doc/htmlxref.cnf (GUIX_ROOT): New variable.
(GUIX, GUIX_COOKBOOK): Adjust.
| Ludovic Courtès |
2021-10-04 | doc: Update htmlxref.cnf....Update and fix broken references to cuirass, git, and guix-cookbook.
* doc/htmlxref.cnf: Update from Texinfo. Factorize Guix manuals.
(cuirass, git, guix-cookbook, guix-cookbook.de, guix-cookbook.fr): New
entries.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Sarah Morgensen |
2021-04-24 | doc: Fix cross-reference URL to translated manual....* doc/htmlxref.cnf: Fix translated manual URL.
| Julien Lepiller |
2020-01-12 | doc: Update htmlxref.cnf....* doc/htmlxref.cnf: Update from Texinfo. Add entries for "mes",
"guix.ru", and "guix.zh_CN".
| Ludovic Courtès |
2019-05-04 | doc: Update htmlxref.cnf....* doc/htmlxref.cnf (G): Switch to https.
(geiser, guix.de, guix.es, hurd): New entries.
| Ludovic Courtès |
2018-07-05 | doc: Update URL of the Emacs-Guix manual....* doc/htmlxref.cnf (EMACS_GUIX): Update URL.
| Ludovic Courtès |
2018-07-05 | doc: Mention translations of the manual....* doc/guix.texi (Top): Add note about l10n.
* doc/htmlxref.cnf: Add "guix.fr".
| Ludovic Courtès |