Fix build against xorg-server >= 1.20. Patch taken from upstream: https://cgit.freedesktop.org/xorg/driver/xf86-video-savage/commit/?id=0ece556daa8a88771b669d8104396abd9166d2d0 diff --git a/src/savage_driver.c b/src/savage_driver.c index 58a294d..3cda923 100644 --- a/src/savage_driver.c +++ b/src/savage_driver.c @@ -2034,8 +2034,6 @@ static Bool SavagePreInit(ScrnInfoPtr pScrn, int flags) xf86DrvMsg(pScrn->scrnIndex, X_PROBED, "Detected current MCLK value of %1.3f MHz\n", mclk / 1000.0); - pScrn->maxHValue = 2048 << 3; /* 11 bits of h_total 8-pixel units */ - pScrn->maxVValue = 2048; /* 11 bits of v_total */ pScrn->virtualX = pScrn->display->virtualX; pScrn->virtualY = pScrn->display->virtualY; @@ -3637,6 +3635,14 @@ static ModeStatus SavageValidMode(SCRN_ARG_TYPE arg, DisplayModePtr pMode, (pMode->VDisplay > psav->PanelY))) return MODE_PANEL; + /* 11 bits of h_total 8-pixel units */ + if (pMode->HTotal > (2048 << 3)) + return MODE_BAD_HVALUE; + + /* 11 bits of v_total */ + if (pMode->VTotal > 2048) + return MODE_BAD_VVALUE; + if (psav->UseBIOS) { refresh = SavageGetRefresh(pMode); return (SavageMatchBiosMode(pScrn,pMode->HDisplay, /tests/mail.scm?showmsg=1'>logtreecommitdiff
path: root/gnu/tests/mail.scm
AgeCommit message (Collapse)Author
2020-11-05services: Remove imports of (ice-9 …) modules.Ludovic Courtès
* gnu/services/monitoring.scm (zabbix-server-activation): Remove (ice-9 rdelim) from the imported modules. (zabbix-agent-activation): Likewise. * gnu/tests/mail.scm (run-exim-test)[test]: Remove (ice-9 ftw) from the imported modules.
2020-03-16tests: opensmtpd: Check /var/spool/mail instead of /var/mail.Ludovic Courtès
The test had been failing since the upgrade to 6.6.3p1 in commit 2dbfd8eec43b602d23cee3fdd2842cc333e36c24. * gnu/services/mail.scm (opensmtpd-activation): Create /var/spool/mail. * gnu/tests/mail.scm (run-opensmtpd-test): Check /var/spool/mail instead of /var/mail.
2020-03-16tests: opensmtpd: Gracefully handle test failure.Ludovic Courtès
Previously the 'wait' loop would run for ~1024 seconds, at which point we'd reach the file descriptor limit due to the leak in 'queue-empty?'. * gnu/tests/mail.scm (run-opensmtpd-test)[test]("mail arrived"): In 'queue-empty?', close PIPE to avoid file descriptor leak. In 'wait' loop, arrange to run at most 20 times.
2020-03-09tests: getmail: Provide a pre-initialized user account password.Ludovic Courtès
* gnu/tests/mail.scm (%getmail-os): Rewrite so that the "alice" account has a password. (run-getmail-test)[test]("set password for alice"): Remove. This would not work since commit 8b9cad01e9619f53dc5a65892ca6a09ca5de3447 since 'passwd' would no longer be in $PATH.
2020-01-31gnu: Update opensmtpd configuration grammar.Tobias Geerinckx-Rice
This follows up on commit 0d486909083c98d7c75cdfc027f89e69f9bf8f48. * gnu/services/mail.scm (%default-opensmtpd-config-file): Adapt to ‘new’ ≥6.4 grammar. * gnu/tests/mail.scm (%opensmtpd-os): Likewise.
2020-01-20tests: mail: Remove %getmail-os from the bottom of the file.Christopher Baines
This was left over when debugging the system test. * gnu/tests/mail.scm: Remove %getmail-os from the bottom of the file.