https://sources.debian.org/src/x265/2.9-3/debian/patches/0001-Fix-arm-flags.patch/ From: Sebastian Ramacher Date: Wed, 26 Apr 2017 22:05:06 +0200 Subject: Fix arm* flags --- source/CMakeLists.txt | 6 +----- 1 file changed, 1 insertion(+), 5 deletions(-) diff --git a/source/CMakeLists.txt b/source/CMakeLists.txt index 33b6523..25aecbb 100644 --- a/source/CMakeLists.txt +++ b/source/CMakeLists.txt @@ -72,7 +72,7 @@ elseif(ARMMATCH GREATER "-1") endif() message(STATUS "Detected ARM target processor") set(ARM 1) - add_definitions(-DX265_ARCH_ARM=1 -DHAVE_ARMV6=1) + # add_definitions(-DX265_ARCH_ARM=1 -DHAVE_ARMV6=1) else() message(STATUS "CMAKE_SYSTEM_PROCESSOR value `${CMAKE_SYSTEM_PROCESSOR}` is unknown") message(STATUS "Please add this value near ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE}") @@ -230,12 +230,8 @@ if(GCC) if(ARM AND CROSS_COMPILE_ARM) set(ARM_ARGS -march=armv6 -mfloat-abi=soft -mfpu=vfp -marm -fPIC) elseif(ARM) - find_package(Neon) if(CPU_HAS_NEON) - set(ARM_ARGS -mcpu=native -mfloat-abi=hard -mfpu=neon -marm -fPIC) add_definitions(-DHAVE_NEON) - else() - set(ARM_ARGS -mcpu=native -mfloat-abi=hard -mfpu=vfp -marm) endif() endif() add_definitions(${ARM_ARGS}) vices/web.scm?id=b7aec88a8f560e3c934b6c1c882277d7886b8dd4'>commitdiff
path: root/gnu/services/web.scm
AgeCommit message (Expand)Author
2024-07-26services: agate: Update options for compatibility with the current Agate vers......Rodion Goritskov
2024-07-10services: web: Return success from nginx-action....Tomas Volf
2024-07-10services: web: Pass run-directory to nginx's actions....Tomas Volf
2024-06-26services: web: Improve nginx formatting for extra-content....Richard Sent
2024-02-20services: Add whoogle-service-type....Miguel Ángel Moreno
2023-12-22services: Remove unnecessary references to (gnu build shepherd)....Ludovic Courtès
2023-12-14services: hpcguix-web: Add ‘configuration’ action....Ludovic Courtès
2023-12-03gnu: gmnisrv: Fix typo....Michal Atlas
2023-12-02gnu: Use ‘libc-utf8-locales-for-target’....Janneke Nieuwenhuizen
2023-07-02services: nginx: Harden php-location settings....Bruno Victal
2023-04-11services: nginx: Add reopen action....Bruno Victal
2023-04-11services: nginx: Make logging level configurable....Bruno Victal
2023-01-22services: hpcguix-web: Provide default values....Ludovic Courtès
2022-11-18services: Add Shepherd 'configuration' action to various services....Ludovic Courtès
2022-11-17services: Streamline or eliminate some match-lambda patterns....Maxim Cournoyer