Fix CVE-2008-2149: buffer overflows by limiting the length of the string in sprintf format string Closes: #481186 (CVE-2008-2149) Please note: The WordNet code contains several other occurences of potentially exploitable functions like strcpy()/strcat()/... and so even if there are no known exploits the code needs a full security audit. --- a/src/wn.c +++ b/src/wn.c @@ -206,7 +206,8 @@ static int searchwn(int ac, char *av[]) outsenses += do_search(av[1], optptr->pos, optptr->search, whichsense, optptr->label); } else { - sprintf(tmpbuf, "wn: invalid search option: %s\n", av[j]); + /* Fix CVE-2008-2149: buffer overflows Andreas Tille */ + sprintf(tmpbuf, "wn: invalid search option: %.200s\n", av[j]); display_message(tmpbuf); errcount++; } d881de06eebdaa1ed98c7212cfc4'/> Reverse engineer's tool for tracing the flow of data in JS program, based on UglifyJS
aboutsummaryrefslogtreecommitdiff
path: root/test/ufuzz.json
diff options
context:
space:
mode:
authorAlex Lam S.L <alexlamsl@gmail.com>2019-10-06 08:51:38 +0800
committerGitHub <noreply@github.com>2019-10-06 08:51:38 +0800
commit35338a100f62d881de06eebdaa1ed98c7212cfc4 (patch)
tree755621a77e6ba08c57b78d8671b13373518ee067 /test/ufuzz.json
parentd57b606e7387c103661538ee9df36dc18199b9ba (diff)
downloadtracifyjs-35338a100f62d881de06eebdaa1ed98c7212cfc4.tar.gz
tracifyjs-35338a100f62d881de06eebdaa1ed98c7212cfc4.zip
handle function/variable name collisions correctly (#3451)
fixes #3439
Diffstat (limited to 'test/ufuzz.json')
0 files changed, 0 insertions, 0 deletions