From: Eric Bavier Date: Sat, 2 Apr 2016 01:31:03 -0500 Subject: [PATCH] Build against external libbrotli. --- Makefile | 20 ++++---------------- src/woff2_dec.cc | 2 +- src/woff2_enc.cc | 2 +- 3 files changed, 6 insertions(+), 18 deletions(-) diff --git a/Makefile b/Makefile index 92b8d54..618a751 100644 --- a/Makefile +++ b/Makefile @@ -1,6 +1,6 @@ OS := $(shell uname) -CPPFLAGS = -I./brotli/dec/ -I./brotli/enc/ -I./src +CPPFLAGS := -I./src $(shell pkg-config --cflags libbrotlienc libbrotlidec) CC ?= gcc CXX ?= g++ @@ -22,29 +22,17 @@ OUROBJ = font.o glyph.o normalize.o table_tags.o transform.o \ woff2_dec.o woff2_enc.o woff2_common.o woff2_out.o \ variable_length.o -BROTLI = brotli -ENCOBJ = $(BROTLI)/enc/*.o -DECOBJ = $(BROTLI)/dec/*.o +BROTLI_LIBS := $(shell pkg-config --libs libbrotlienc libbrotlidec) OBJS = $(patsubst %, $(SRCDIR)/%, $(OUROBJ)) EXECUTABLES=woff2_compress woff2_decompress EXE_OBJS=$(patsubst %, $(SRCDIR)/%.o, $(EXECUTABLES)) -ifeq (,$(wildcard $(BROTLI)/*)) - $(error Brotli dependency not found : you must initialize the Git submodule) -endif - all : $(OBJS) $(EXECUTABLES) -$(EXECUTABLES) : $(EXE_OBJS) deps - $(CXX) $(LFLAGS) $(OBJS) $(ENCOBJ) $(DECOBJ) $(SRCDIR)/$@.o -o $@ - -deps : - $(MAKE) -C $(BROTLI)/dec - $(MAKE) -C $(BROTLI)/enc +$(EXECUTABLES) : $(EXE_OBJS) $(OBJS) + $(CXX) $(LDFLAGS) $(OBJS) $(SRCDIR)/$@.o -o $@ $(BROTLI_LIBS) $(LIBS) clean : rm -f $(OBJS) $(EXE_OBJS) $(EXECUTABLES) - $(MAKE) -C $(BROTLI)/dec clean - $(MAKE) -C $(BROTLI)/enc clean diff --git a/src/woff2_dec.cc b/src/woff2_dec.cc index 837eede..98c01ce 100644 --- a/src/woff2_dec.cc +++ b/src/woff2_dec.cc @@ -27,7 +27,7 @@ #include #include -#include "./decode.h" +#include "brotli/dec/decode.h" #include "./buffer.h" #include "./port.h" #include "./round.h" diff --git a/src/woff2_enc.cc b/src/woff2_enc.cc index 920c614..00d74da 100644 --- a/src/woff2_enc.cc +++ b/src/woff2_enc.cc @@ -23,7 +23,7 @@ #include #include -#include "./encode.h" +#include "brotli/enc/encode.h" #include "./buffer.h" #include "./font.h" #include "./normalize.h" -- 2.7.3 href='/guix/log/po/doc?id=d3d00b1b4f2875675999919fa7e892c36bfff4c6'>doc/guix-manual.es.po
AgeCommit message (Expand)Author
2022-06-04nls: Update translations....Julien Lepiller
2022-05-01nls: Update translations....Julien Lepiller
2022-04-02nls: Update translations....Julien Lepiller
2022-03-01nls: Update translations....Julien Lepiller
2022-02-04nls: Update translations....Julien Lepiller
2022-01-09nls: Update translations....Julien Lepiller
2021-12-04nls: Update translations.Julien Lepiller
2021-11-06nls: Update translations....Julien Lepiller
2021-10-17nls: Update translations.Julien Lepiller
2021-09-02nls: Update translations....Julien Lepiller
2021-08-04nls: Update translations....Julien Lepiller
2021-05-10nls: Update translations.Maxim Cournoyer
2021-04-18nls: Update 'es' translations.Julien Lepiller
2020-11-12nls: Update translations of the manual.Ludovic Courtès
2020-10-27nls: Update.Ludovic Courtès
2020-10-16nls: Update manual translations.Ludovic Courtès
2020-04-12nls: Update.Ludovic Courtès
2020-03-23nls: Update.Ludovic Courtès
2020-02-14Revert "nls: Update 'es' translation of the manual."...Christopher Baines
2020-02-14nls: Update 'es' translation of the manual.Julien Lepiller