Description: Correct 64 Architecture implementation of 32 bit data Author: Chris Donoghue Bug-Debian: http://bugs.debian.org/362068 --- wmctrl-1.07.orig/main.c +++ wmctrl-1.07/main.c @@ -1425,6 +1425,16 @@ static gchar *get_property (Display *dis * * long_length = Specifies the length in 32-bit multiples of the * data to be retrieved. + * + * NOTE: see + * http://mail.gnome.org/archives/wm-spec-list/2003-March/msg00067.html + * In particular: + * + * When the X window system was ported to 64-bit architectures, a + * rather peculiar design decision was made. 32-bit quantities such + * as Window IDs, atoms, etc, were kept as longs in the client side + * APIs, even when long was changed to 64 bits. + * */ if (XGetWindowProperty(disp, win, xa_prop_name, 0, MAX_PROPERTY_VALUE_LEN / 4, False, xa_prop_type, &xa_ret_type, &ret_format, @@ -1441,6 +1451,8 @@ static gchar *get_property (Display *dis /* null terminate the result to make string handling easier */ tmp_size = (ret_format / 8) * ret_nitems; + /* Correct 64 Architecture implementation of 32 bit data */ + if(ret_format==32) tmp_size *= sizeof(long)/4; ret = g_malloc(tmp_size + 1); memcpy(ret, ret_prop, tmp_size); ret[tmp_size] = '\0'; guix-package.sh?id=f9671ab689b2743797e974a2260473543add7b3a'>commitdiff
path: root/tests/guix-package.sh
AgeCommit message (Expand)Author
2015-04-19guix package: -A and -s take supported systems into account....Ludovic Courtès
2015-04-06tests: Move 'guix package' tests that require networking to a separate file....Ludovic Courtès
2015-04-06guix package: Never remove the current generation and warn about it....Ludovic Courtès
2015-02-24tests: Skip tests that would fail due to the shebang length....Ludovic Courtès
2015-02-06guix package: Make custom profiles actual indirect roots....Ludovic Courtès
2015-01-03gnu: Search for patches under $GUIX_PACKAGE_PATH....Ludovic Courtès
2014-12-06guix: scripts: Parse $GUIX_BUILD_OPTIONS separately....nebuli
2014-10-12guix package: Add '--switch-generation' option....Alex Kost
2014-10-10build: Make sure tests/guix-package.sh doesn't leave anything behind it....Ludovic Courtès
2014-09-24Introduce the 'GUIX_PACKAGE_PATH' environment variable....Ludovic Courtès
2014-09-24guix build: Add -L/--load-path as a common option....Ludovic Courtès