Description: Correct 64 Architecture implementation of 32 bit data Author: Chris Donoghue Bug-Debian: http://bugs.debian.org/362068 --- wmctrl-1.07.orig/main.c +++ wmctrl-1.07/main.c @@ -1425,6 +1425,16 @@ static gchar *get_property (Display *dis * * long_length = Specifies the length in 32-bit multiples of the * data to be retrieved. + * + * NOTE: see + * http://mail.gnome.org/archives/wm-spec-list/2003-March/msg00067.html + * In particular: + * + * When the X window system was ported to 64-bit architectures, a + * rather peculiar design decision was made. 32-bit quantities such + * as Window IDs, atoms, etc, were kept as longs in the client side + * APIs, even when long was changed to 64 bits. + * */ if (XGetWindowProperty(disp, win, xa_prop_name, 0, MAX_PROPERTY_VALUE_LEN / 4, False, xa_prop_type, &xa_ret_type, &ret_format, @@ -1441,6 +1451,8 @@ static gchar *get_property (Display *dis /* null terminate the result to make string handling easier */ tmp_size = (ret_format / 8) * ret_nitems; + /* Correct 64 Architecture implementation of 32 bit data */ + if(ret_format==32) tmp_size *= sizeof(long)/4; ret = g_malloc(tmp_size + 1); memcpy(ret, ret_prop, tmp_size); ret[tmp_size] = '\0'; c85d51f082681a9f4fa911867afba'>commitdiff
path: root/tests/utils.scm
AgeCommit message (Expand)Author
2024-04-15utils: Don’t re-export ‘call-with-temporary-output-file’....Ludovic Courtès
2024-02-23utils: Add find-definition-insertion-location procedure....Herman Rimm
2024-02-23utils: Add insert-expression procedure....Herman Rimm
2023-12-11guix: Add target-avr?....Jean-Pierre De Jesus DIAZ
2021-07-14utils: Define a target-x86-32? and target-x86-64? predicate....Maxime Devos
2021-07-14utils: Define 'target-linux?' predicate....Maxime Devos
2021-02-03utils: Add string distance....zimoun
2021-02-01utils: Add 'version-unique-prefix'....Ludovic Courtès
2021-01-13utils: Support zstd compression via Guile-zstd....Ludovic Courtès
2021-01-13utils: Remove 'compressed-output-port'....Ludovic Courtès
2020-08-24Use "guile-zlib" and "guile-lzlib" instead of (guix config)....Mathieu Othacehe
2019-06-20utils: canonical-newline-port: Fix handling of carriage return at buffer end....Robert Vollmert
2019-05-27utils: Support compression and decompression with lzip....Ludovic Courtès
2019-05-27utils: Test 'compressed-port' and 'decompressed-port' for both gzip and xz....Ludovic Courtès