backend/drm: add hardcoded hwdata path fallback
Add hardcoded fallback "/usr/share/hwdata/pnp.ids" as a
temporary solution to get things working in Guix until
hwdata ships with pkg-config file.
diff --git a/backend/drm/meson.build b/backend/drm/meson.build
index 6fcb2c15..ed95360a 100644
--- a/backend/drm/meson.build
+++ b/backend/drm/meson.build
@@ -1,8 +1,7 @@
hwdata = dependency(
'hwdata',
- required: 'drm' in backends,
+ required: false,
native: true,
- not_found_message: 'Required for the DRM backend.',
)
libdisplay_info = dependency(
@@ -19,15 +18,21 @@ libliftoff = dependency(
required: false,
)
-if not (hwdata.found() and libdisplay_info.found() and features['session'])
+if hwdata.found()
+ hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
+ pnp_ids = files(hwdata_dir / 'pnp.ids')
+else
+ pnp_ids = files('/usr/share/hwdata/pnp.ids')
+endif
+
+if not (libdisplay_info.found() and features['session'])
subdir_done()
endif
-hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
pnpids_c = custom_target(
'pnpids.c',
output: 'pnpids.c',
- input: files(hwdata_dir / 'pnp.ids'),
+ input: pnp_ids,
feed: true,
capture: true,
command: files('gen_pnpids.sh'),
/guix/tree/tests/records.scm?id=2f7e80102defc6c4e469d1dc94441e7f054e5310'>treecommitdiff
|
Age | Commit message (Expand) | Author |
2023-06-04 | tests: records: Add test for ellipsis in body....* tests/records.scm ("match-record, ellipsis in body"): New test.
| Josselin Poiret |
2023-06-04 | records: Add MATCH-RECORD-LAMBDA....* guix/records.scm (match-record-lambda): New syntax.
* tests/records.scm ("match-record-lambda"): New test.
Signed-off-by: Josselin Poiret <dev@jpoiret.xyz>
| (unmatched-parenthesis ew syntax |
2023-06-04 | records: match-record: Support thunked and delayed fields....* guix/records.scm (match-record): Unwrap matched thunked and delayed fields.
* tests/records.scm ("match-record, thunked field",
"match-record, delayed field"): New tests.
Signed-off-by: Josselin Poiret <dev@jpoiret.xyz>
| (unmatched-parenthesis d |
2022-12-27 | records: match-record supports specifying a different variable name....An example:
(match-record obj <my-type>
(field1 (field2 custom-var-name) field3)
...)
* guix/records.scm (match-record-inner): Add support for the new syntax.
* tests/records.scm ("match-record, simple"): Add a simple test case for the
new syntax.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Attila Lendvai |
2022-12-02 | records: 'match-record' checks fields at macro-expansion time....This allows 'match-record' to be more efficient (field offsets are
computed at compilation time) and to report unknown fields at
macro-expansion time.
* guix/records.scm (map-fields): New macro.
(define-record-type*)[rtd-identifier]: New procedure.
Define TYPE as a macro and use a separate identifier for the RTD.
(lookup-field, match-record-inner): New macros.
(match-record): Rewrite in terms of 'match-error-inner'.
* tests/records.scm ("match-record, simple")
("match-record, unknown field"): New tests.
* gnu/services/cuirass.scm (cuirass-shepherd-service): Rename 'log-file'
local variable to 'main-log-file'.
* gnu/services/getmail.scm (serialize-getmail-configuration-file): Move
after <getmail-configuration-file> definition.
| Ludovic Courtès |
2022-07-01 | tests: Add sanitizer test....* tests/records.scm ("define-record-type* & sanitize without default
value"): New test.
| Ludovic Courtès |
2021-08-12 | records: Support field sanitizers....* guix/records.scm (make-syntactic-constructor): Add #:sanitizers.
[field-sanitizer]: New procedure.
[wrap-field-value]: Honor F's sanitizer.
(define-record-type*)[field-sanitizer]: New procedure.
Pass #:sanitizer to 'make-syntactic-constructor'.
* tests/records.scm ("define-record-type* & sanitize")
("define-record-type* & sanitize & thunked"): New tests.
| Ludovic Courtès |
2021-04-29 | diagnostics, ui: Adjust to 'read-error' and 'syntax-error' in Guile 3.0.6....* guix/diagnostics.scm (source-properties->location): Add clause for
vectors.
* guix/ui.scm (report-load-error): Tweak 'read-error' handling for 3.0.6.
* tests/guix-package.sh: Relax regexp for the "unbound variable"
diagnostic check.
* tests/guix-system.sh: Adjust "missing closing paren" check for 3.0.6.
* tests/records.scm (location-alist): New procedure.
("define-record-type* & wrong field specifier")
("define-record-type* & wrong field specifier, identifier")
("define-record-type* & duplicate initializers"): Use it.
| Ludovic Courtès |