Wicd 1.7.3 fails to instantiate template lines that have several variable references. For instance, the line: wep_key$_KEY_INDEX=$_KEY which is found in in the 'wep-hex' template, expands to these two lines: wep_key0=$_KEY wep_key0=123456789ab This patch fixes that by only emitting the fully substituted line. Patch by Ludovic Courtès . --- a/wicd/misc.py 2012-11-17 00:07:08 +0000 +++ b/wicd/misc.py 2015-05-09 11:22:37 +0000 @@ -321,11 +321,11 @@ def ParseEncryption(network): rep_val = '0' if rep_val: line = line.replace("$_%s" % cur_val, str(rep_val)) - config_file = ''.join([config_file, line]) else: print "Ignoring template line: '%s'" % line else: print "Weird parsing error occurred" + config_file = ''.join([config_file, line]) else: # Just a regular entry. config_file = ''.join([config_file, line]) 956a190a91c39f9eb2'>refslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-02-04 15:23:45 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-05-10 22:13:55 +0200
commitad0ae297d4b5af5b7eaf29956a190a91c39f9eb2 (patch)
tree8ae2d15499301ce442d8994be425aebc10e1e86a
parentde59e24abe9b35054b5de4389244625cdf8a4527 (diff)
downloadguix-ad0ae297d4b5af5b7eaf29956a190a91c39f9eb2.tar.gz
guix-ad0ae297d4b5af5b7eaf29956a190a91c39f9eb2.zip
gnu: Add taxtastic.
* gnu/packages/bioinformatics.scm (taxtastic): New variable.