Fix copied from https://bugs.launchpad.net/wicd/+bug/1421918/comments/2 --- wicd-1.7.3/curses/wicd-curses.py 2014-12-21 16:57:33 +0000 +++ wicd-1.7.3/curses/wicd-curses.py 2015-02-24 23:41:01 +0000 @@ -532,7 +532,10 @@ def get_selected_profile(self): """Get the selected wired profile""" loc = self.get_focus()[1] - return self.theList[loc] + if len(self.theList) > loc: + return self.theList[loc] + else: + return self.theList[-1] class AdHocDialog(Dialog2): form'>
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/build-aux
AgeCommit message (Expand)Author
2016-12-18build: check-final-inputs-self-contained has an exception for 'bash:include'....Ludovic Courtès
2016-12-08hydra: Fix wrong-num-args error when computing the cross jobs....Ludovic Courtès
2016-12-08hydra: Adjust to make-bootstrap.scm change....Ludovic Courtès
2016-12-08hydra: Use '%final-inputs' from base.scm, not commencement.scm....Ludovic Courtès
2016-12-07hydra: Add "i686-w64-mingw32" as a cross-compilation target....Ludovic Courtès
2016-11-27pull: Hack to allow compilation with older Guile-SSH packages....Ludovic Courtès
2016-11-26pull: Add guile-ssh to the dependencies....宋文武
2016-11-03tests: 'make check-system' prints the "build trace"....Ludovic Courtès