Fix copied from https://bugs.launchpad.net/wicd/+bug/1421918/comments/2 --- wicd-1.7.3/curses/wicd-curses.py 2014-12-21 16:57:33 +0000 +++ wicd-1.7.3/curses/wicd-curses.py 2015-02-24 23:41:01 +0000 @@ -532,7 +532,10 @@ def get_selected_profile(self): """Get the selected wired profile""" loc = self.get_focus()[1] - return self.theList[loc] + if len(self.theList) > loc: + return self.theList[loc] + else: + return self.theList[-1] class AdHocDialog(Dialog2): '>
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu.scm
AgeCommit message (Expand)Author
2020-07-25Use 'formatted-message' instead of '&message' where appropriate....Ludovic Courtès
2020-07-25utils: Move '&fix-hint' to (guix diagnostics)....Ludovic Courtès
2020-07-25utils: Move <location> and '&error-location' to (guix diagnostics)....Ludovic Courtès
2019-03-24Add (gnu system keyboard)....Ludovic Courtès
2017-11-08gnu: Improve error reporting of the use-.*modules macros....Ludovic Courtès
2017-05-16bootloader: Add extlinux support....Mathieu Othacehe