Fix copied from https://bugs.launchpad.net/wicd/+bug/1432423/comments/1 --- wicd-1.7.3/curses/netentry_curses.py 1969-12-31 19:00:00.000000000 -0500 +++ wicd-1.7.3/curses/netentry_curses.py 2015-08-11 23:26:19.999999649 -0400 @@ -538,11 +538,16 @@ self.bitrates = wireless.GetAvailableBitrates() self.bitrates.append('auto') self.bitrate_combo.set_list(self.bitrates) + + # bitrate property is sometimes None + chosen_bitrate = wireless.GetWirelessProperty(networkID, 'bitrate') + if chosen_bitrate not in self.bitrates: + chosen_bitrate = 'auto' + self.bitrate_combo.set_focus( - self.bitrates.index( - wireless.GetWirelessProperty(networkID, 'bitrate') - ) + self.bitrates.index(chosen_bitrate) ) + self.allow_lower_bitrates_chkbox.set_state( to_bool(self.format_entry(networkID, 'allow_lower_bitrates')) ) ass='sub right'>
aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests/databases.scm
AgeCommit message (Expand)Author
2022-01-29tests: Add system test for TimescaleDB....Marius Bakke
2022-01-29tests: postgresql: Test the default PostgreSQL....Marius Bakke
2021-09-27services: database: Change postgresql default socket....Mathieu Othacehe
2021-09-26tests: Reduce boilerplate for users of 'system-test-runner'....Ludovic Courtès
2021-09-25tests: Adjust to SRFI-64 as found in Guile 3.0.7....Ludovic Courtès
2021-04-13tests: postgresql: Fix it....Mathieu Othacehe
2021-03-16gnu: Remove MongoDB....Léo Le Bouter
2021-01-28services: postgresql: Add postgresql-role-service-type....Mathieu Othacehe
2021-01-28services: postgresql: Add log directory support....Mathieu Othacehe
2021-01-28services: postgresql: Use Guile datatypes....Mathieu Othacehe
2020-11-28services: MySQL: Add more tests....Marius Bakke
2020-11-28services: MySQL: Upgrade database schemas automatically....Marius Bakke
2020-11-28services: MySQL: Deprecate 'mysql-service'....Marius Bakke
2020-10-20services: databases: Don't specify a default postgresql version....Christopher Baines