Fix copied from https://bugs.launchpad.net/wicd/+bug/1432423/comments/1 --- wicd-1.7.3/curses/netentry_curses.py 1969-12-31 19:00:00.000000000 -0500 +++ wicd-1.7.3/curses/netentry_curses.py 2015-08-11 23:26:19.999999649 -0400 @@ -538,11 +538,16 @@ self.bitrates = wireless.GetAvailableBitrates() self.bitrates.append('auto') self.bitrate_combo.set_list(self.bitrates) + + # bitrate property is sometimes None + chosen_bitrate = wireless.GetWirelessProperty(networkID, 'bitrate') + if chosen_bitrate not in self.bitrates: + chosen_bitrate = 'auto' + self.bitrate_combo.set_focus( - self.bitrates.index( - wireless.GetWirelessProperty(networkID, 'bitrate') - ) + self.bitrates.index(chosen_bitrate) ) + self.allow_lower_bitrates_chkbox.set_state( to_bool(self.format_entry(networkID, 'allow_lower_bitrates')) ) '>
aboutsummaryrefslogtreecommitdiff
path: root/gnu/services.scm
AgeCommit message (Expand)Author
2019-12-07services: Add 'provenance-service-type'....Ludovic Courtès
2019-11-09services: 'fold-services' memoizes service values....Ludovic Courtès
2019-08-14remote: Remove '--system' argument....Jakob L. Kreuze
2019-05-10services: 'gc-root-service-type' now has a default value....Ludovic Courtès
2018-09-07services: 'instantiate-missing-services' reaches fixed point....Ludovic Courtès
2018-06-20services: boot: Take gexps instead of monadic gexps....Ludovic Courtès
2018-06-20services: Add description to core services....Ludovic Courtès
2018-06-20services: cleanup: Expect file names to be UTF-8-encoded....Ludovic Courtès
2018-06-20services: boot: Reverse the order of boot expressions....Ludovic Courtès
2018-04-08discovery: Remove dependency on (guix ui)....Ludovic Courtès
2018-03-29gnu: Refactor boot-service-type and activation-service-type....Chris Marusich
2018-01-21services: Missing services are automatically instantiated....Ludovic Courtès
2017-12-17services: cleanup: Remove "/run/udev/watch.old" directory....Danny Milosavljevic