https://bugs.gentoo.org/921140
https://gitlab.freedesktop.org/pulseaudio/webrtc-audio-processing/-/issues/5
--- a/webrtc/rtc_base/system/arch.h
+++ b/webrtc/rtc_base/system/arch.h
@@ -34,7 +34,7 @@
#else
#define WEBRTC_ARCH_32_BITS
#endif
-#elif defined(_M_IX86) || defined(__i386__)
+#elif defined(__SSE__) && (defined(_M_IX86) || defined(__i386__))
#define WEBRTC_ARCH_X86_FAMILY
#define WEBRTC_ARCH_X86
#define WEBRTC_ARCH_32_BITS
szko.org/cgit-static/cgit.png' alt='cgit logo'/>
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Collapse) | Author |
|
* gnu/packages/java-compression.scm (java-xz): Update to 1.9.
[arguments]: Build with openjdk9.
|
|
* gnu/packages/java-compression.scm (java-xz)[source]: Download source
as zipbomb.
[argments]: Remove custom 'chdir phase.
|
|
* gnu/packages/java-compression.scm (java-snappy)[arguments]: Add
set-test-memory-size phase.
This fixes <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=46780>.
Thanks to zimoun for the solving idea.
The CachingBufferPoolTest tries to allocate a lot of memory (20GB) and the
test succeeds if there is not enough memory available in the JVM.
When the build machine has a lot of memory (which is the case on the Guix
CI system), the JVM will use more than 20GB as maximum heap size. In
consequence, the test fails.
The new phase adds a maxmemory size of 2G for the tests. Thus all other
tests will have enough memory and the CachingBufferPoolTest will fail.
|