Description: The H5FD_class_t struct gained an extra member in 1.10 Bug-Debian: https://bugs.debian.org/846372 Author: Iain Lane --- a/ThirdParty/xdmf2/vtkxdmf2/libsrc/XdmfH5Driver.cxx +++ b/ThirdParty/xdmf2/vtkxdmf2/libsrc/XdmfH5Driver.cxx @@ -139,7 +139,11 @@ #if (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=8)) static haddr_t H5FD_dsm_get_eoa(const H5FD_t *_file, H5FD_mem_t type); static herr_t H5FD_dsm_set_eoa(H5FD_t *_file, H5FD_mem_t type, haddr_t addr); +#if (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=10)) +static haddr_t H5FD_dsm_get_eof(const H5FD_t *_file, H5FD_mem_t type); +#else static haddr_t H5FD_dsm_get_eof(const H5FD_t *_file); +#endif #else static haddr_t H5FD_dsm_get_eoa(H5FD_t *_file); static herr_t H5FD_dsm_set_eoa(H5FD_t *_file, haddr_t addr); @@ -155,6 +159,9 @@ "dsm", /*name */ MAXADDR, /*maxaddr */ H5F_CLOSE_WEAK, /*fc_degree */ +#if (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=8)) + NULL, /* terminate */ +#endif NULL, /*sb_size */ NULL, /*sb_encode */ NULL, /*sb_decode */ @@ -687,7 +694,9 @@ *------------------------------------------------------------------------- */ static haddr_t -#if (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=8)) +#if (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=10)) +H5FD_dsm_get_eof(const H5FD_t *_file, H5FD_mem_t type) +#elif (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=8)) H5FD_dsm_get_eof(const H5FD_t *_file) #else H5FD_dsm_get_eof(H5FD_t *_file) ge
path: root/nix
AgeCommit message (Expand)Author
2022-04-14daemon: Support systemd-style socket activation....Ludovic Courtès
2022-01-18daemon: Always default to gzip for log compression....Ludovic Courtès
2021-11-27daemon: Print the line whence we expect an integer....Tobias Geerinckx-Rice
2021-11-25daemon: Read substitute nar size as 'unsigned long long'....Ludovic Courtès
2021-11-25daemon: Read unsigned nar size and download size from substituter....Ludovic Courtès
2021-11-19daemon: Micro-optimize 'deletePath'....Ludovic Courtès
2021-11-16daemon: Do not deduplicate files smaller than 8 KiB....Ludovic Courtès
2021-10-01build: Don’t delete ‘guix-gc.timer’ file....Xinglu Chen