Description: The H5FD_class_t struct gained an extra member in 1.10 Bug-Debian: https://bugs.debian.org/846372 Author: Iain Lane --- a/ThirdParty/xdmf2/vtkxdmf2/libsrc/XdmfH5Driver.cxx +++ b/ThirdParty/xdmf2/vtkxdmf2/libsrc/XdmfH5Driver.cxx @@ -139,7 +139,11 @@ #if (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=8)) static haddr_t H5FD_dsm_get_eoa(const H5FD_t *_file, H5FD_mem_t type); static herr_t H5FD_dsm_set_eoa(H5FD_t *_file, H5FD_mem_t type, haddr_t addr); +#if (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=10)) +static haddr_t H5FD_dsm_get_eof(const H5FD_t *_file, H5FD_mem_t type); +#else static haddr_t H5FD_dsm_get_eof(const H5FD_t *_file); +#endif #else static haddr_t H5FD_dsm_get_eoa(H5FD_t *_file); static herr_t H5FD_dsm_set_eoa(H5FD_t *_file, haddr_t addr); @@ -155,6 +159,9 @@ "dsm", /*name */ MAXADDR, /*maxaddr */ H5F_CLOSE_WEAK, /*fc_degree */ +#if (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=8)) + NULL, /* terminate */ +#endif NULL, /*sb_size */ NULL, /*sb_encode */ NULL, /*sb_decode */ @@ -687,7 +694,9 @@ *------------------------------------------------------------------------- */ static haddr_t -#if (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=8)) +#if (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=10)) +H5FD_dsm_get_eof(const H5FD_t *_file, H5FD_mem_t type) +#elif (H5_VERS_MAJOR>1)||((H5_VERS_MAJOR==1)&&(H5_VERS_MINOR>=8)) H5FD_dsm_get_eof(const H5FD_t *_file) #else H5FD_dsm_get_eof(H5FD_t *_file) option value='range'>range
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2017-01-21 14:27:15 -0800
committer宋文武 <iyzsong@member.fsf.org>2017-01-22 12:36:17 +0800
commitd6c73cb4c4f9c6611fc5b3ca2277dc5dd01a24bb (patch)
tree1e37c190f7f63cc780f7dcded785720895268b15
parentec3487a664660500b4c4a82210f40b603ab1c84e (diff)
downloadguix-d6c73cb4c4f9c6611fc5b3ca2277dc5dd01a24bb.tar.gz
guix-d6c73cb4c4f9c6611fc5b3ca2277dc5dd01a24bb.zip
gnu: perl-term-readkey: Update to 2.37.
The previous version, 2.32, is not available for download anymore. * gnu/packages/perl.scm (perl-term-readkey): Update to 2.37. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/perl.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 09278f4251..fb294eb42d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5950,7 +5950,7 @@ done, how much is left to do, and estimate how long it will take.")
(define-public perl-term-readkey
(package
(name "perl-term-readkey")
- (version "2.32")
+ (version "2.37")
(source
(origin
(method url-fetch)
@@ -5958,7 +5958,7 @@ done, how much is left to do, and estimate how long it will take.")
"TermReadKey-" version ".tar.gz"))
(sha256
(base32
- "1y79w5cj98w0a1nqxjhmaw01p2hfhzfw340m2qxd11p6124hxfaq"))))
+ "0hdj5mldpj3pyprd4hbbalfx9yjgi5p59gg2ixk9808f5v7q74sa"))))
(build-system perl-build-system)
(home-page "http://search.cpan.org/dist/TermReadKey")
(synopsis "Simple terminal control")