Retrieved from
https://sources.debian.org/src/vtk7/7.1.1%2Bdfsg2-10.1/debian/patches/.
--- a/CMake/VTKGenerateExportHeader.cmake
+++ b/CMake/VTKGenerateExportHeader.cmake
@@ -174,7 +174,7 @@
execute_process(COMMAND ${CMAKE_C_COMPILER} --version
OUTPUT_VARIABLE _gcc_version_info
ERROR_VARIABLE _gcc_version_info)
- string(REGEX MATCH "[3-9]\\.[0-9]\\.[0-9]*"
+ string(REGEX MATCH "[0-9]*\\.[0-9]\\.[0-9]*"
_gcc_version "${_gcc_version_info}")
# gcc on mac just reports: "gcc (GCC) 3.3 20030304 ..." without the
# patch level, handle this here:
form method='get'>
gnu: elfutils: Fix build for 64bit Hurd....* gnu/packages/elf.scm (elfutils)[arguments]: When building for a 64bit Hurd,
set #:make-flags.
Change-Id: I00abf360a7de5b1f78c1e912f0dcf27c62c1af68
gnu: patchelf: Fix test suite....* gnu/packages/elf.scm (patchelf)[arguments]: Adjust 'fix-tests phase
for changes in the test suite.
Change-Id: Iffeb4ef94e0d78edd47d9d8b6e316f3b29627ed0
Efraim Flashner
2024-08-31
gnu: patchelf: Update to 0.18.0....* gnu/packages/elf.scm (patchelf): Update to 0.18.0.
Change-Id: I094841b6cbd9ac2eb9dcab132e28be5c3acb3cb4
Maxim Cournoyer
2024-08-31
gnu: patchelf: Update to 0.17.2....* gnu/packages/elf.scm (patchelf): Update to 0.17.2.
[uri]: Use the release tarballs posted to GitHub releases, which have
superseded the ones hosted on releases.nixos.org.
[arguments]: Add fixes for two tests added since the last update.
[properties]: Remove release-monitoring-url, as the GitHub updater will
be used now that the releases are hosted there.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>