Retrieved from https://sources.debian.org/src/vtk7/7.1.1%2Bdfsg2-10.1/debian/patches/. --- a/CMake/VTKGenerateExportHeader.cmake +++ b/CMake/VTKGenerateExportHeader.cmake @@ -174,7 +174,7 @@ execute_process(COMMAND ${CMAKE_C_COMPILER} --version OUTPUT_VARIABLE _gcc_version_info ERROR_VARIABLE _gcc_version_info) - string(REGEX MATCH "[3-9]\\.[0-9]\\.[0-9]*" + string(REGEX MATCH "[0-9]*\\.[0-9]\\.[0-9]*" _gcc_version "${_gcc_version_info}") # gcc on mac just reports: "gcc (GCC) 3.3 20030304 ..." without the # patch level, handle this here: 'get'> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/build/svg.scm
='left'>Commit message (Collapse)
AgeCommit message (Expand)Author
Author
2023-07-19tests: gdm: Prefer OCR to delay.Bruno Victal
* gnu/tests/gdm.scm (run-gdm-test): Use wait-for-screen-text instead of sleep. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
2023-03-21tests: gdm: Remove tmpfs related tests.Bruno Victal
This test never managed to reveal the problem described in [1] because from gnu/system/vm.scm it is seen that our "/tmp" mount is filtered out and replaced with a "/tmp" file-system that is mounted with (needed-for-boot? #t). This last bit is crucial as the problem was caused by the user specified "/tmp" file-system lacking this part which caused "/tmp" being mounted after x11-socket-directory-service has run, effectively shadowing the directory. [1]: <https://issues.guix.gnu.org/57589> * gnu/tests/gdm.scm (%test-gdm-wayland-tmpfs): Delete variable. (make-os): Remove tmpfs? argument. (run-gdm-test): Remove tmpfs? argument. Add a small delay since waiting for gdm.pid is not enough, causing the tests to fail sporadically. Reviewed-by: Josselin Poiret <dev@jpoiret.xyz> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
2022-12-04tests: Add gdm tests.Bruno Victal
* gnu/tests/gdm.scm: New file. * gnu/local.mk: Register it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>