From feeee4b5832b17641e505b7083e0d299fdae318e Mon Sep 17 00:00:00 2001 From: Christian Persch Date: Sat, 19 May 2012 17:36:09 +0000 Subject: emulation: Limit integer arguments to 65535 To guard against malicious sequences containing excessively big numbers, limit all parsed numbers to 16 bit range. Doing this here in the parsing routine is a catch-all guard; this doesn't preclude enforcing more stringent limits in the handlers themselves. https://bugzilla.gnome.org/show_bug.cgi?id=676090 --- diff --git a/src/table.c b/src/table.c index 140e8c8..85cf631 100644 --- a/src/table.c +++ b/src/table.c @@ -550,7 +550,7 @@ _vte_table_extract_numbers(GValueArray **array, if (G_UNLIKELY (*array == NULL)) { *array = g_value_array_new(1); } - g_value_set_long(&value, total); + g_value_set_long(&value, CLAMP (total, 0, G_MAXUSHORT)); g_value_array_append(*array, &value); } while (i++ < arginfo->length); g_value_unset(&value); diff --git a/src/vteseq.c b/src/vteseq.c index 457c06a..46def5b 100644 --- a/src/vteseq.c +++ b/src/vteseq.c @@ -557,7 +557,7 @@ vte_sequence_handler_multiple(VteTerminal *terminal, GValueArray *params, VteTerminalSequenceHandler handler) { - vte_sequence_handler_multiple_limited(terminal, params, handler, G_MAXLONG); + vte_sequence_handler_multiple_limited(terminal, params, handler, G_MAXUSHORT); } static void -- cgit v0.9.0.2 input type='hidden' name='id' value='fb42a8d996999da1717cc9366ebfab25cf6a5921'/>
path: root/m4
AgeCommit message (Expand)Author
2022-01-14gnu: bootstrap: Add support for riscv64-linux....Efraim Flashner
2021-12-14build: Adjust 'courage level' of different systems....Efraim Flashner
2021-05-23gnu: bootstrap: Add support for powerpc-linux....Efraim Flashner
2021-03-23Add powerpc64le-linux as a supported Guix architecture....Chris Marusich
2021-03-17maint: Check whether Guile-zlib is recent enough....Ludovic Courtès
2021-02-04build: Add '--with-channel-commit' and related configure flags....Ludovic Courtès
2020-12-11maint: Avoid macros obsolete in Autoconf 2.70....Ludovic Courtès
2020-10-22git: Require Guile-Git 0.3.0 or later....Ludovic Courtès
2020-09-08Remove (guix json) and require Guile-JSON 4.3.0+....Ludovic Courtès
2020-08-29build: Remove check for Guile 2.2.1 bug....Ludovic Courtès
2020-08-24Use "guile-zlib" and "guile-lzlib" instead of (guix config)....Mathieu Othacehe
2020-07-20ssh: Speed up RPCs by using #:nodelay....Lars-Dominik Braun
2020-05-28doc: Remove explicit support for mips64el-linux....Efraim Flashner
2020-05-28maint: Check whether Guile-Gcrypt is recent enough....Ludovic Courtès
2020-02-22build: Depend on guile-ssh 0.12.0...Lars-Dominik Braun