diff --git a/src/Makefile.am b/src/Makefile.am index e56a8a2..4adcc48 100644 --- a/src/Makefile.am +++ b/src/Makefile.am @@ -3,7 +3,7 @@ bin_PROGRAMS = $(top_builddir)/bin/vsearch if TARGET_PPC AM_CXXFLAGS=-Wall -Wsign-compare -O3 -g -mcpu=power8 else -AM_CXXFLAGS=-Wall -Wsign-compare -O3 -g -march=x86-64 -mtune=generic +AM_CXXFLAGS=-Wall -Wsign-compare -O3 -g -lcityhash endif AM_CFLAGS=$(AM_CXXFLAGS) @@ -18,8 +18,6 @@ allpairs.h \ arch.h \ bitmap.h \ chimera.h \ -city.h \ -citycrc.h \ cluster.h \ cpu.h \ db.h \ @@ -59,31 +57,26 @@ xstring.h if TARGET_PPC libcpu_a_SOURCES = cpu.cc $(VSEARCHHEADERS) -noinst_LIBRARIES = libcpu.a libcityhash.a +noinst_LIBRARIES = libcpu.a else libcpu_sse2_a_SOURCES = cpu.cc $(VSEARCHHEADERS) libcpu_sse2_a_CXXFLAGS = $(AM_CXXFLAGS) -msse2 libcpu_ssse3_a_SOURCES = cpu.cc $(VSEARCHHEADERS) libcpu_ssse3_a_CXXFLAGS = $(AM_CXXFLAGS) -mssse3 -DSSSE3 -noinst_LIBRARIES = libcpu_sse2.a libcpu_ssse3.a libcityhash.a +noinst_LIBRARIES = libcpu_sse2.a libcpu_ssse3.a endif -libcityhash_a_SOURCES = city.cc city.h - if TARGET_WIN -libcityhash_a_CXXFLAGS = $(AM_CXXFLAGS) -Wno-sign-compare -D_MSC_VER -__top_builddir__bin_vsearch_LDFLAGS = -static -__top_builddir__bin_vsearch_LDADD = libregex.a libcityhash.a libcpu_ssse3.a libcpu_sse2.a +__top_builddir__bin_vsearch_LDFLAGS = -static -lcityhash +__top_builddir__bin_vsearch_LDADD = libregex.a libcpu_ssse3.a libcpu_sse2.a else -libcityhash_a_CXXFLAGS = $(AM_CXXFLAGS) -Wno-sign-compare - if TARGET_PPC -__top_builddir__bin_vsearch_LDADD = libcityhash.a libcpu.a +__top_builddir__bin_vsearch_LDADD = libcpu.a else -__top_builddir__bin_vsearch_LDADD = libcityhash.a libcpu_ssse3.a libcpu_sse2.a +__top_builddir__bin_vsearch_LDADD = libcpu_ssse3.a libcpu_sse2.a endif endif diff --git a/src/vsearch.h b/src/vsearch.h index f2c244b..5f51bbe 100644 --- a/src/vsearch.h +++ b/src/vsearch.h @@ -148,7 +148,7 @@ #include #endif -#include "city.h" +#include #include "md5.h" #include "sha1.h" 7f3d5483e2e2e5c4b6c70b0b93c82'>README
r>
AgeCommit message (Expand)Author
2020-10-23doc: Update README....Maxim Cournoyer
2020-10-22README: Refer to the manual for building from Git....Maxim Cournoyer
2020-06-02doc: Update README to refer to the manual....Ludovic Courtès
2019-11-09doc: Mention value /var to localstatedir option....zimoun
2019-09-04doc: Update 'README'....Ludovic Courtès
2024-04-06gnu: opencolorio: Update to 2.3.2....Vinicius Monego
2024-03-27gnu: insight-toolkit: Build and install Python bindings....Ricardo Wurmus
2024-03-25gnu: opencv: Update to 4.9.0....Andy Tai
2024-03-23gnu: gmic: Update to 3.3.5....Vinicius Monego
2024-02-13gnu: opencv: Update to 4.8.1....Andy Tai
2024-02-09gnu: vxl: Update to 3.5.0....Felix Gruber
2024-01-19gnu: gmic: Update to 3.3.3....Vinicius Monego
2023-12-05gnu: python-imgviz: Adjust for newer python....Efraim Flashner
2023-11-14gnu: insight-toolkit-4.12: Fix building....Efraim Flashner
2023-09-24gnu: opencv: Add descriptors for xfeatures2d....Ricardo Wurmus