Upstream fix for CVE-2015-6749. https://trac.xiph.org/ticket/2212 From 04815d3e1bfae3a6cdfb2c25358a5a72b61299f7 Mon Sep 17 00:00:00 2001 From: Mark Harris Date: Sun, 30 Aug 2015 05:54:46 -0700 Subject: [PATCH] oggenc: Fix large alloca on bad AIFF input Fixes #2212 --- oggenc/audio.c | 10 +++++----- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/oggenc/audio.c b/oggenc/audio.c index 477da8c..4921fb9 100644 --- a/oggenc/audio.c +++ b/oggenc/audio.c @@ -245,8 +245,8 @@ static int aiff_permute_matrix[6][6] = int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen) { int aifc; /* AIFC or AIFF? */ - unsigned int len; - unsigned char *buffer; + unsigned int len, readlen; + unsigned char buffer[22]; unsigned char buf2[8]; aiff_fmt format; aifffile *aiff = malloc(sizeof(aifffile)); @@ -269,9 +269,9 @@ int aiff_open(FILE *in, oe_enc_opt *opt, unsigned char *buf, int buflen) return 0; /* Weird common chunk */ } - buffer = alloca(len); - - if(fread(buffer,1,len,in) < len) + readlen = len < sizeof(buffer) ? len : sizeof(buffer); + if(fread(buffer,1,readlen,in) < readlen || + (len > readlen && !seek_forward(in, len-readlen))) { fprintf(stderr, _("Warning: Unexpected EOF in reading AIFF header\n")); return 0; -- 2.5.0 mmit/doc/htmlxref.cnf?id=f7d4399618104c8da845311829033122dee53027'>commitdiff
path: root/doc/htmlxref.cnf
AgeCommit message (Collapse)Author
2024-06-03nls: Update translations.Florian Pelz
* po/doc/guix-cookbook.sv.po: New file. * po/doc/local.mk: Add 'sv' cookbook. * po/doc/po4a.cfg (po4a_langs): Add 'sv'. * doc/local.mk: Add 'sv' cookbook. * doc/htmlxref.cnf: Update URLs for cookbook. * doc/build.scm (%cookbook-languages): Add 'sv'. * doc/guix-cookbook.texi (Top): Mention 'sv' cookbook. Change-Id: Ibfeb7254f583f1c8827e8c2756bbb02880bcba46
2024-04-01nls: Update translations.Florian Pelz
* po/guix/ar.po: New file. * po/guix/LINGUAS: Add 'ar'. * po/doc/guix-cookbook.pt_BR.po: New file. * po/doc/local.mk: Add 'pt_BR' cookbook. * doc/local.mk: Add 'pt_BR' cookbook. * doc/htmlxref.cnf: Update URLs for cookbook. * doc/build.scm (%cookbook-languages): Add 'ko', 'pt_BR'. * doc/guix-cookbook.texi (Top): Mention 'ko', 'pt_BR' cookbook. Change-Id: Id1846ca100263b3fc1fa2ed52654c670270ee809
2022-12-18doc: Update URLs for the manual and cookbook translations.Ludovic Courtès
* doc/htmlxref.cnf: Update URLs for "guix" and "guix-cookbook".
2022-12-18doc: Add guile-netlink to 'htmlxref.cnf'.Ludovic Courtès
* doc/htmlxref.cnf: Add guile-netlink.