Fix build with Boost + Python 3.7. Taken from upstream: https://github.com/ukoethe/vigra/commit/a6fa62663c6a6b752ed0707e95f643e25867a0f9 diff --git a/vigranumpy/src/core/vigranumpycore.cxx b/vigranumpy/src/core/vigranumpycore.cxx index ec38d3636..c81c6ae52 100644 --- a/vigranumpy/src/core/vigranumpycore.cxx +++ b/vigranumpy/src/core/vigranumpycore.cxx @@ -61,7 +61,7 @@ UInt32 pychecksum(python::str const & s) return checksum(data, size); #else Py_ssize_t size = 0; - char * data = PyUnicode_AsUTF8AndSize(s.ptr(), &size); + const char * data = PyUnicode_AsUTF8AndSize(s.ptr(), &size); return checksum(data, size); #endif } 'id' value='87a10e315f60a198875dec31665b6a8775c9ca9c'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
AgeCommit message (Expand)Author
2022-06-23gnu: python-bandit: Update to 1.7.4....jgart
2022-06-21gnu: python-cliff: Update to 3.10.1....Marius Bakke
2022-01-18gnu: Adjust merge resolution....Marius Bakke
2022-01-17Merge branch 'version-1.4.0'...Maxim Cournoyer
2022-01-10gnu: python-os-testr: Propagate python-testtools and python-babel....Maxim Cournoyer
2022-01-12gnu: python-oslo.log: Update to 4.6.1....Marius Bakke
2022-01-12gnu: python-oslo.serialization: Update to 4.2.0....Marius Bakke
2022-01-12gnu: python-oslo.utils: Update to 4.12.0....Marius Bakke
2022-01-12gnu: python-oslo.config: Update to 8.7.1....Marius Bakke
2022-01-11gnu: python-os-testr: Add python-testrepository to inputs....Tanguy Le Carrour
2022-01-11gnu: python-oslo.i18n: Disable tests....Marius Bakke
2022-01-11gnu: python-os-testr: Update to 2.0.1....Marius Bakke