Fix build with Boost + Python 3.7. Taken from upstream: https://github.com/ukoethe/vigra/commit/a6fa62663c6a6b752ed0707e95f643e25867a0f9 diff --git a/vigranumpy/src/core/vigranumpycore.cxx b/vigranumpy/src/core/vigranumpycore.cxx index ec38d3636..c81c6ae52 100644 --- a/vigranumpy/src/core/vigranumpycore.cxx +++ b/vigranumpy/src/core/vigranumpycore.cxx @@ -61,7 +61,7 @@ UInt32 pychecksum(python::str const & s) return checksum(data, size); #else Py_ssize_t size = 0; - char * data = PyUnicode_AsUTF8AndSize(s.ptr(), &size); + const char * data = PyUnicode_AsUTF8AndSize(s.ptr(), &size); return checksum(data, size); #endif } 85b92332b09a481db74cc60392787ac2'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/config-daemon.ac
AgeCommit message (Expand)Author
2019-11-27daemon: GC remove-unused-links phase uses 'statx' when available....Ludovic Courtès
2019-11-13daemon: Don't include <linux/fs.h>....Ludovic Courtès
2019-09-08daemon: Run 'guix substitute' directly and assume a single substituter....Ludovic Courtès
2019-09-08daemon: Run 'guix offload' directly....Ludovic Courtès
2019-09-08daemon: Run 'guix perform-download' directly....Ludovic Courtès
2019-09-08daemon: Run 'guix authenticate' directly....Ludovic Courtès
2019-09-08daemon: Invoke 'guix gc --list-busy' instead of 'list-runtime-roots'....Ludovic Courtès