This patch was copied from Debian. Description: skip the workbuf test if VB2_WORKBUF_ALIGN different from 16 Author: Sophie Brun Last-Update: 2015-12-03 --- This patch header follows DEP-3: http://dep.debian.net/deps/dep3/ --- a/tests/vb2_common_tests.c +++ b/tests/vb2_common_tests.c @@ -70,6 +70,11 @@ static void test_workbuf(void) /* NOTE: There are several magic numbers below which assume that * VB2_WORKBUF_ALIGN == 16 */ + /* Skip the tests if VB2_WORKBUF_ALIGN != 16 */ + if (VB2_WORKBUF_ALIGN != 16) { + return; + } + /* Init */ vb2_workbuf_init(&wb, p0, 64); TEST_EQ(vb2_offset_of(p0, wb.buf), 0, "Workbuf init aligned"); owmsg' value='1'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/uucp.scm
AgeCommit message (Collapse)Author
2024-06-29gnu: nncp: Apply "-trimpath" flag.Sharlatan Hellseher
* gnu/packages/uucp.scm (nncp) [arguments]: <#:phases>: Remove 'remove-go-references phase. Set BUILDFLAGS=-trimpath to replace 'remove-go-references phase in 'configure phase. Change-Id: I7cfe14174e38708d36329d8e33ed6bb1ce0ae220
2024-02-13gnu: go-github-com-klauspost-compress: Move to golang-compression.Sharlatan Hellseher
* gnu/packages/golang.scm (go-github-com-klauspost-compress): Move from here ... * gnu/packages/golang-compression.scm: ... to here. * gnu/packages/golang-compression.scm: Add (gnu packages golang-compression) module. * gnu/packages/golang-crypto.scm: As above. * gnu/packages/golang-web.scm: As above. * gnu/packages/uucp.scm: As above. Change-Id: Ia99f1e6aae7f75940fc150eb02862c0b3e9f3325
2024-02-13gnu: go-golang-org-x-net: Move to golang-build.Sharlatan Hellseher
* gnu/packages/golang.scm (go-golang-org-x-net, go-golang-org-x-net-0.17, go-golang-org-x-net-html): Move from here ... * gnu/packages/golang-build.scm: ... to here. * gnu/packages/configuration-management.scm: Add (gnu packages golang-build) module. * gnu/packages/education.scm: As above ... * gnu/packages/file-systems.scm: As above ... * gnu/packages/golang-check.scm: As above ... * gnu/packages/golang-crypto.scm: As above ... * gnu/packages/golang-web.scm: As above ... * gnu/packages/golang-xyz.scm: As above ... * gnu/packages/golang.scm: As above ... * gnu/packages/ipfs.scm: As above ... * gnu/packages/messaging.scm: As above ... * gnu/packages/networking.scm: As above ... * gnu/packages/uucp.scm: As above ... * gnu/packages/version-control.scm: As above ... Change-Id: If009e62555ada293f17cf0f42fde82c21ef4615e
2024-01-28gnu: go-lukechampine-com-blake3: Move to (gnu packages golang-crypto).Sharlatan Hellseher
* gnu/packages/golang.scm (go-lukechampine-com-blake3): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. * gnu/packages/uucp.scm: Add (gnu packages golang-crypto) to used modules. Change-Id: I56dba8380317a0f58f92140889611ac3075af2cf
2024-01-03gnu: go-github-com-hjson-hjson-go: Move to (gnu packages golang-web).Sharlatan Hellseher
* gnu/packages/golang.scm (go-github-com-hjson-hjson-go): Move from here... * gnu/packages/golang-web.scm: ...to here. * gnu/packages/networking.scm: Add (gnu packages golang-web) module. * gnu/packages/uucp.scm: As above. Change-Id: If1ba5e4d866ce74fa35ae9126c6ba4cd0b149dab