This patch was copied from Debian. Description: skip the workbuf test if VB2_WORKBUF_ALIGN different from 16 Author: Sophie Brun Last-Update: 2015-12-03 --- This patch header follows DEP-3: http://dep.debian.net/deps/dep3/ --- a/tests/vb2_common_tests.c +++ b/tests/vb2_common_tests.c @@ -70,6 +70,11 @@ static void test_workbuf(void) /* NOTE: There are several magic numbers below which assume that * VB2_WORKBUF_ALIGN == 16 */ + /* Skip the tests if VB2_WORKBUF_ALIGN != 16 */ + if (VB2_WORKBUF_ALIGN != 16) { + return; + } + /* Init */ vb2_workbuf_init(&wb, p0, 64); TEST_EQ(vb2_offset_of(p0, wb.buf), 0, "Workbuf init aligned"); name='h' onchange='this.form.submit();'> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
AgeCommit message (Expand)Author
2022-05-15gnu: openfst: Update to 1.8.2, enable ngram extension...Aurora
2022-05-15gnu: openfst-1.7.3: Enable ngram-fst extension & C++14 build...Aurora
2022-05-15gnu: kaldi: Update to dd107fd, bypass tests...Aurora
2022-05-15gnu: openfst: Add 1.7.3 for kaldi...Aurora
2022-05-12gnu: python-umap-learn: Update to 0.5.3....Maxim Cournoyer
2022-05-12gnu: python-pynndescent: Update to 0.5.6....Maxim Cournoyer
2022-05-12gnu: python-scikit-learn: Parallelize build and test suite....Maxim Cournoyer
2022-04-15gnu: python-hmmlearn: Remove cythonized file....Efraim Flashner
2022-03-15gnu: liblantern: Update to 0.7.2....Ricardo Wurmus
2022-03-15gnu: liblantern: Update to 0.7.0....Ricardo Wurmus
2022-03-15gnu: python-pytorch-for-r-torch: Reuse python-pytorch....Ricardo Wurmus
2022-02-11gnu: Add liblantern....Ricardo Wurmus
2022-02-11gnu: Add python-pytorch-for-r-torch....Ricardo Wurmus
2022-02-11gnu: python-pytorch: Update to 1.10.2....Ricardo Wurmus