This patch was copied from Debian. Description: Fix format load_address for 32 bits architectures The offset and load_address are 64bits integers On 32bits we have to use strtoull (instead of strtoul) to parse number into 64bits unsigned integers. Without this the parsed numbers are truncated to 2^32-1. Author: Sophie Brun Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=881997 Forwarded: https://bugs.chromium.org/p/chromium/issues/detail?id=786969 Last-Update: 2017-11-20 --- This patch header follows DEP-3: http://dep.debian.net/deps/dep3/ --- a/futility/cmd_bdb.c +++ b/futility/cmd_bdb.c @@ -637,7 +637,7 @@ static int do_bdb(int argc, char *argv[] } break; case OPT_OFFSET: - offset = strtoul(optarg, &e, 0); + offset = strtoull(optarg, &e, 0); if (!*optarg || (e && *e)) { fprintf(stderr, "Invalid --offset\n"); parse_error = 1; @@ -658,7 +658,7 @@ static int do_bdb(int argc, char *argv[] } break; case OPT_LOAD_ADDRESS: - load_address = strtoul(optarg, &e, 0); + load_address = strtoull(optarg, &e, 0); if (!*optarg || (e && *e)) { fprintf(stderr, "Invalid --load_address\n"); parse_error = 1; ix/log/etc/snippets/yas?showmsg=1'>logtreecommitdiff
path: root/etc/snippets/yas
AgeCommit message (Collapse)Author
2023-02-19etc: Add a news entry snippet.Maxim Cournoyer
* etc/snippets/yas/scheme-mode/guix-news-entry: New file.
2022-11-28snippets: yas: Add snippets for vc.elMorgan Smith
* etc/snippets/yas/log-edit-mode/guix-vc-commit-message-add-package: * etc/snippets/yas/log-edit-mode/guix-vc-commit-message-remove-package: * etc/snippets/yas/log-edit-mode/guix-vc-commit-message-rename-package: * etc/snippets/yas/log-edit-mode/guix-vc-commit-message-update-package: * etc/snippets/yas/log-edit-mode/guix-vc-commit-message-use-https-home-page: New file Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2022-08-30etc: Update yasnippet build system list.Nicolas Graves
* etc/snippets/yas/scheme-mode/guix-package (build-system): Add chicken-build-system, minetest-build-system, rebar-build-system and renpy-build-system. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
2022-08-30etc: Add tempel snippets.Nicolas Graves
* etc/snippets/tempel/scheme-mode: New file. * etc/snippets/tempel/text-mode: New file. * etc/snippets/scheme-mode: Moved from here... * etc/snippets/yas/scheme-mode: ... to here. * etc/snippets/text-mode: Moved from here... * etc/snippets/yas/text-mode: ... to here. * doc/contributing.texi ("The Perfect Setup"): Adjust yasnippet setup accordingly. Add tempel setup. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>