This patch was copied from Debian. Description: Fix format load_address for 32 bits architectures The offset and load_address are 64bits integers On 32bits we have to use strtoull (instead of strtoul) to parse number into 64bits unsigned integers. Without this the parsed numbers are truncated to 2^32-1. Author: Sophie Brun Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=881997 Forwarded: https://bugs.chromium.org/p/chromium/issues/detail?id=786969 Last-Update: 2017-11-20 --- This patch header follows DEP-3: http://dep.debian.net/deps/dep3/ --- a/futility/cmd_bdb.c +++ b/futility/cmd_bdb.c @@ -637,7 +637,7 @@ static int do_bdb(int argc, char *argv[] } break; case OPT_OFFSET: - offset = strtoul(optarg, &e, 0); + offset = strtoull(optarg, &e, 0); if (!*optarg || (e && *e)) { fprintf(stderr, "Invalid --offset\n"); parse_error = 1; @@ -658,7 +658,7 @@ static int do_bdb(int argc, char *argv[] } break; case OPT_LOAD_ADDRESS: - load_address = strtoul(optarg, &e, 0); + load_address = strtoull(optarg, &e, 0); if (!*optarg || (e && *e)) { fprintf(stderr, "Invalid --load_address\n"); parse_error = 1; sh'>logtreecommitdiff
path: root/etc/completion/fish
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2019-12-23 17:20:33 -0600
committerBrett Gilio <brettg@gnu.org>2019-12-23 17:20:33 -0600
commit0066f6be05f3bb1d8d40aa84065a739e66589cd0 (patch)
tree71419aba08494a33a2ff75588ff044375e94978a /etc/completion/fish
parentd8de20a3a666a7c063ac94f067dbebf3b546b00d (diff)
downloadguix-0066f6be05f3bb1d8d40aa84065a739e66589cd0.tar.gz
guix-0066f6be05f3bb1d8d40aa84065a739e66589cd0.zip
gnu: python-sphinx: Update to 2.3.1.
* gnu/packages/sphinx.scm (python-sphinx): Update to 2.3.1.
Diffstat (limited to 'etc/completion/fish')
0 files changed, 0 insertions, 0 deletions