This test checks whether 'root' is successfully translated to UID/GID 0,
using 'getpwnam' in libmount. This doesn't work in the chroot because
/etc/passwd doesn't contain an entry for 'root' so skip it.
The second test requires that '/sys/dev/block' is present, which is not
the case inside the build container.
--- util-linux-2.25.2/tests/ts/libmount/optstr 2015-01-23 13:58:41.181151194 +0100
+++ util-linux-2.25.2/tests/ts/libmount/optstr 2015-01-23 13:58:42.829161716 +0100
@@ -108,10 +108,6 @@
ts_run $TESTPROG --apply --user "noexec,nosuid,loop=/dev/looop0" 0x408 &> $TS_OUTPUT
ts_finalize_subtest
-ts_init_subtest "fix"
-ts_run $TESTPROG --fix "uid=root,gid=root" &> $TS_OUTPUT
-ts_finalize_subtest
-
ts_init_subtest "deduplicate"
ts_run $TESTPROG --dedup bbb,ccc,AAA,xxx,AAA=a,AAA=bbb,ddd,AAA=ccc,fff=eee AAA &> $TS_OUTPUT
ts_finalize_subtest
--- a/tests/ts/lsblk/lsblk 2019-03-11 21:08:23.734387391 +0100
+++ b/tests/ts/lsblk/lsblk 2019-03-11 21:12:43.635473111 +0100
@@ -22,6 +22,8 @@
ts_init "$*"
+ts_skip "/sys/dev/block is not available"
+
ts_check_test_command "$TS_CMD_LSBLK"
ts_check_prog xz
ts_check_prog tar
efslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2022-07-03 | etc: Add teams.scm....* etc/teams.scm.in: New file.
* configure.ac: Generate executable.
* .gitignore: Ignore generated file.
| Ricardo Wurmus |
2022-01-25 | build: Require Guile >= 3.0.3....Fixes <https://issues.guix.gnu.org/53157>.
Reported by Efraim Flashner <efraim@flashner.co.il>.
* configure.ac: Require Guile >= 3.0.3.
* doc/guix.texi (Requirements): Update accordingly.
| Ludovic Courtès |
2021-11-23 | maint: "make dist" builds tarballs in 'ustar' format....This allows us to have file names longer than 99 characters.
* configure.ac: Pass 'tar-ustar' to 'AM_INIT_AUTOMAKE'.
| Ludovic Courtès |
2021-06-01 | maint: Require Guile 3.0....* configure.ac: Require Guile 3.0.
* doc/guix.texi (Requirements): Adjust accordingly.
* gnu/packages/package-management.scm (guile2.2-guix): Remove.
* guix/lint.scm (exception-with-kind-and-args?): Remove 'cond-expand'.
* guix/scripts/deploy.scm (deploy-machine*): Likewise.
* guix/store.scm (call-with-store): Likewise.
* guix/swh.scm (http-get*, http-post*): Likewise.
* guix/ui.scm (without-compiler-optimizations, guard*)
(call-with-error-handling): Likewise.
| Ludovic Courtès |
2021-05-03 | nls: Do not update po files on first make invocation....We need to update the minimal gettext version to take advantage of new
features. Before this patch, the first make invocation would modify
po/guix and po/packages po files, and we advised to run `git checkout
po` to clean the changes.
* configure.ac (AM_GNU_GETTEXT_VERSION): Update to 0.19.1.
* po/guix/Makevars: Set PO_DEPENDS_ON_POT to no.
* po/packages/Makevars: Set PO_DEPENDS_ON_POT to no.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
| Julien Lepiller |
2021-04-25 | import: Remove Nix importer....This importer has suffered from bitrot and no longer works with current
Nix and Nixpkgs. See <https://bugs.gnu.org/32339> and
<https://bugs.gnu.org/36255>.
* guix/import/snix.scm, guix/scripts/import/nix.scm,
tests/snix.scm: Remove.
* Makefile.am (MODULES, SCM_TESTS): Remove them.
* guix/scripts/import.scm (importers): Remove "nix".
* build-aux/test-env.in: Remove NIXPKGS variable.
* configure.ac: Remove '--with-nixpkgs' option.
* doc/guix.texi (Invoking guix import): Remove bit about "guix import
nix".
* etc/completion/fish/guix.fish: Likewise.
| Ludovic Courtès |
2021-04-23 | build: Add a check for Guile-Lib....* configure.ac: Check if the Guile-Lib module is present and recent enough and
warn in case it isn't.
| Maxim Cournoyer |