--- old/usb_modeswitch.tcl 1970-01-01 01:00:00.000000000 +0100
+++ usb_modeswitch.tcl 2019-06-12 08:39:42.140000000 +0200
@@ -41,7 +41,7 @@
global scsi usb config match device flags setup devdir loginit
set flags(config) ""
-Log "[ParseGlobalConfig]"
+Log "[ParseGlobalConfig $argv]"
if {$flags(stordelay) > 0} {
SetStorageDelay $flags(stordelay)
@@ -496,9 +496,21 @@
# end of proc {MatchDevice}
-proc {ParseGlobalConfig} {} {
+proc {ParseGlobalConfig} {argv} {
global flags
+
+set configFileParam ""
+for {set i 0} {$i < [llength $argv]} {incr i} {
+ switch -glob -- [set v [lindex $argv $i]] {
+ --config-file=* {
+ set configFileParam $v
+ }
+ }
+}
+if {$configFileParam != ""} {
+ set configFile [string range $configFileParam [string length "--config-file="] end]
+} else {
set configFile ""
set places [list /etc/usb_modeswitch.conf /etc/sysconfig/usb_modeswitch /etc/default/usb_modeswitch]
foreach cfg $places {
@@ -507,6 +519,7 @@
break
}
}
+}
if {$configFile == ""} {return}
set rc [open $configFile r]
ix/refs/?id=b25f44b636dcf4ab43da83b95497b7078e03393c'>refslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2024-05-25 | maint: Suggest ‘guix git authenticate’ for initial authentication....The previous recommendation, running ‘make authenticate’, was insecure
because it led users to run code from the very repository they want to
authenticate:
https://lists.gnu.org/archive/html/guix-devel/2024-04/msg00252.html
* Makefile.am (commit_v1_0_0, channel_intro_commit)
(channel_intro_signer, GUIX_GIT_KEYRING, authenticate): Remove.
* Makefile.am (.git/hooks/%): New target, generalization of previous
‘.git/hooks/pre-push’ target.
(nodist_noinst_DATA): Add ‘.git/hooks/post-merge’.
* doc/contributing.texi (Building from Git): Suggest ‘guix git
authenticate’ instead of ‘make authenticate’.
* etc/git/post-merge: New file.
* etc/git/pre-push: Run ‘guix git authenticate’ instead of ‘make
authenticate’.
Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Reported-by: Skyler Ferris <skyvine@protonmail.com>
Change-Id: Ia415aa8375013d0dd095e891116f6ce841d93efd
| Ludovic Courtès |
2024-01-24 | gitconfig: b4: Automatically add 'Signed-off-by' when applying patches....Also use --3way to ease conflict resolutions.
* etc/git/gitconfig [b4]: Add shazam-am-flags option.
Change-Id: I6a92909a5b23a8680c16251aafa084b9a48944ea
| Maxim Cournoyer |
2023-11-07 | doc: Add some guidelines for reviewing....* doc/contributing.texi (Contributing) [Reviewing the Work of Others]: New
section.
(Debbugs Usertags): Expound with Emacs Debbugs information and document the
'reviewed-looks-good' usertag.
* etc/git/gitconfig [b4]: New section.
Change-Id: I56630b15ec4fbc5c67e5420dbf2838556a005d6b
Reviewed-by: Ludovic Courtès <ludo@gnu.org>
| Maxim Cournoyer |
2023-10-22 | build: Add a commit-msg hook that embeds Change-Id in commit messages....Partially implements <https://issues.guix.gnu.org/66027>.
This will make it possible to track a merged commit back to its original
posting on the mailing list, and open the door to new opportunities such as
closing fully merged series automatically.
* Makefile.am (COMMIT_MSG_MAGIC): New variable.
(.git/hooks/commit-msg): New target.
* etc/git/commit-msg: New file.
* doc/contributing.texi (Configuring Git): Document Change-Id.
Series-changes: 3
- Clarify documentation text, as suggested by Simon
Change-Id: Ia92fa958eae600fdd4e180bad494c85db8bb4dd6
Reviewed-by: Simon Tournier <zimon.toutoune@gmail.com>
| Maxim Cournoyer |