--- old/usb_modeswitch.tcl 1970-01-01 01:00:00.000000000 +0100 +++ usb_modeswitch.tcl 2019-06-12 08:39:42.140000000 +0200 @@ -41,7 +41,7 @@ global scsi usb config match device flags setup devdir loginit set flags(config) "" -Log "[ParseGlobalConfig]" +Log "[ParseGlobalConfig $argv]" if {$flags(stordelay) > 0} { SetStorageDelay $flags(stordelay) @@ -496,9 +496,21 @@ # end of proc {MatchDevice} -proc {ParseGlobalConfig} {} { +proc {ParseGlobalConfig} {argv} { global flags + +set configFileParam "" +for {set i 0} {$i < [llength $argv]} {incr i} { + switch -glob -- [set v [lindex $argv $i]] { + --config-file=* { + set configFileParam $v + } + } +} +if {$configFileParam != ""} { + set configFile [string range $configFileParam [string length "--config-file="] end] +} else { set configFile "" set places [list /etc/usb_modeswitch.conf /etc/sysconfig/usb_modeswitch /etc/default/usb_modeswitch] foreach cfg $places { @@ -507,6 +519,7 @@ break } } +} if {$configFile == ""} {return} set rc [open $configFile r] /guix/'>summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0df9b9d195..72f284fd15 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2016 Albin Söderqvist <albin@fripost.org>
;;; Copyright © 2016, 2017, 2018 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Steve Webber <webber.sl@gmail.com>
;;; Copyright © 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@hyperbola.info>
@@ -312,6 +312,7 @@ tired of cows, a variety of other ASCII-art messengers are available.")
#:tests? #f ; no check target
#:phases
(modify-phases %standard-phases
+ (delete 'bootstrap)
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((dejavu (assoc-ref inputs "font-dejavu"))