From 41beb477c5744bc396fa1162ee0c14218ec12213 Mon Sep 17 00:00:00 2001 From: Mark Adler Date: Mon, 27 May 2019 08:20:32 -0700 Subject: [PATCH] Fix bug in undefer_input() that misplaced the input state. --- fileio.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/fileio.c b/fileio.c index c042987..bc00d74 100644 --- a/fileio.c +++ b/fileio.c @@ -530,8 +530,10 @@ void undefer_input(__G) * This condition was checked when G.incnt_leftover was set > 0 in * defer_leftover_input(), and it is NOT allowed to touch G.csize * before calling undefer_input() when (G.incnt_leftover > 0) - * (single exception: see read_byte()'s "G.csize <= 0" handling) !! + * (single exception: see readbyte()'s "G.csize <= 0" handling) !! */ + if (G.csize < 0L) + G.csize = 0L; G.incnt = G.incnt_leftover + (int)G.csize; G.inptr = G.inptr_leftover - (int)G.csize; G.incnt_leftover = 0; x/about/'>aboutsummaryrefslogtreecommitdiff
path: root/.gitignore
AgeCommit message (Expand)Author
2020-06-28.gitignore: Ignore 'etc/committer.scm'....Brice Waegeneire
2020-05-16etc: Add a systemd unit to bind-mount @storedir@ read-only....Tobias Geerinckx-Rice
2020-05-14etc: indent-code.el: Use the --quick option....Maxim Cournoyer
2020-03-30.gitignore: Ignore test results in tests/services....Marius Bakke
2020-03-11Add system start-up files for guix-daemon....Danny Milosavljevic
2019-09-24Merge branch 'master' into core-updatesLudovic Courtès
2019-09-18doc: Add Guix Cookbook....Ricardo Wurmus
2019-06-14build: Remove 'gnu/packages/bootstrap' and its binaries....Ludovic Courtès
2019-04-26bootstrap: Break automake dependency on generated files....Miguel Ángel Arruga Vivas
2018-11-20.gitignore: Re-add 'authenticate' script....Marius Bakke
2018-06-14Remove 'guix-register' and its traces....Ludovic Courtès
2018-06-12.gitignore: Add doc/stamp-[0-9].Ludovic Courtès
2018-04-19gnu: doc: Allow documentation to be translated....Julien Lepiller
2018-02-13.gitignore: Add guix-daemon SELinux policy....Efraim Flashner