--- ./process.c.orig 2009-03-06 02:25:10.000000000 +0100
+++ ./process.c 2013-09-12 10:51:16.000000000 +0200
@@ -2901,9 +2901,9 @@
*/
#ifdef IZ_HAVE_UXUIDGID
- if (eb_len >= EB_UX3_MINLEN
- && z_uidgid != NULL
- && (*((EB_HEADSIZE + 0) + ef_buf) == 1)
+ if ((eb_len >= EB_UX3_MINLEN)
+ && (z_uidgid != NULL)
+ && ((*((EB_HEADSIZE + 0) + ef_buf) == 1)))
/* only know about version 1 */
{
uch uid_size;
@@ -2915,10 +2915,10 @@
flags &= ~0x0ff; /* ignore any previous UNIX field */
if ( read_ux3_value((EB_HEADSIZE + 2) + ef_buf,
- uid_size, z_uidgid[0])
+ uid_size, &z_uidgid[0])
&&
read_ux3_value((EB_HEADSIZE + uid_size + 3) + ef_buf,
- gid_size, z_uidgid[1]) )
+ gid_size, &z_uidgid[1]) )
{
flags |= EB_UX2_VALID; /* signal success */
}
fslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2023-07-23 | gnu: fuse@3: Bind to default FUSE variable....* gnu/packages/linux.scm (fuse): Rename this…
(fuse-2): …to this, and…
(fuse-3): …rename this…
(fuse): …to this!
(fuse-static): Rename this…
(fuse-2-static): …to this.
Adjust all users.
| Tobias Geerinckx-Rice |
2023-07-02 | gnu: nextcloud-client: Update to 3.8.2....* gnu/packages/sync.scm (nextcloud-client): Update to 3.8.2.
[snippets]: Keep 3rd-party files from kirigami. Remove more references of
deleted 3rd parties. Adjust substitute for new code.
[configure-flags]: Disable building the updater.
[phases]<patch-cmake>: Adjust substitute for new code.
<check>: Use custom phase to disable a failing test.
[inputs]: Add dbus and karchive.
[native-inputs]: Add librsvg-for-system.
| Hartmut Goebel |
2023-06-14 | gnu: onedrive: Link to all necessary libraries....Reported by adanska on IRC.
* gnu/packages/sync.scm (onedrive)[arguments]: Remove custom
'link-to-external-libraries phase to allow linking to more libraries.
| Efraim Flashner |
2023-04-07 | gnu: curl-minimal: Remove variable....* gnu/packages/curl.scm (curl-minimal): Remove variable.
* gnu/packages/astronomy.scm (python-fitsio, gnuastro): Use curl.
* gnu/packages/games.scm (odamex): Ditto.
* gnu/packages/sync.scm (onedrive): Ditto.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Bruno Victal |
2023-02-04 | gnu: megacmd: Update to 1.5.1 and add libuv dependency....* gnu/packages/sync.scm (megacmd): Update to 1.5.1.
[inputs]: Remove labels and add LIBUV.
Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
| Wamm K. D |
2023-01-10 | gnu: onedrive: Update to 2.4.23....* gnu/packages/sync.scm (onedrive): Update to 2.4.23.
| Efraim Flashner |
2023-01-02 | gnu: onedrive: Update to 2.4.22....* gnu/packages/sync.scm (onedrive): Update to 2.4.22.
[arguments]: Adjust 'link-to-external-libraries phase to not clear the
linker. Adjust 'adjust-makefile phase to not force adding libraries to
the rpath.
| Efraim Flashner |
2022-11-15 | gnu: Add onedrive....* gnu/packages/sync.scm (onedrive): New variable.
| Efraim Flashner |