diff --git a/fileio.c b/fileio.c index ba0a1d0..03fc4be 100644 --- a/fileio.c +++ b/fileio.c @@ -2006,6 +2006,7 @@ int do_string(__G__ length, option) /* return PK-type error code */ unsigned comment_bytes_left; unsigned int block_len; int error=PK_OK; + unsigned int length2; #ifdef AMIGA char tmp_fnote[2 * AMIGA_FILENOTELEN]; /* extra room for squozen chars */ #endif @@ -2292,8 +2293,12 @@ int do_string(__G__ length, option) /* return PK-type error code */ seek_zipf(__G__ G.cur_zipfile_bufstart - G.extra_bytes + (G.inptr-G.inbuf) + length); } else { - if (readbuf(__G__ (char *)G.extra_field, length) == 0) + if ((length2 = readbuf(__G__ (char *)G.extra_field, length)) == 0) return PK_EOF; + if(length2 < length) { + memset (__G__ (char *)G.extra_field+length2, 0 , length-length2); + length = length2; + } /* Looks like here is where extra fields are read */ getZip64Data(__G__ G.extra_field, length); #ifdef UNICODE_SUPPORT fs/?id=59d7f4ff0eca8598bc0411b26083916418cd1f9e'>refslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
AgeCommit message (Expand)Author
2023-05-24gnu: graphviz: Add "minimal" variant....Ludovic Courtès
2023-04-26gnu: graphviz: Remove version 2.38....Andreas Enge
2023-04-19gnu: xdot: Complete atk to at-spi2-core transition....Ludovic Courtès
2023-03-31gnu: Replace all uses of atk by at-spi2-core....Josselin Poiret
2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Christopher Baines
2023-02-21gnu: python-graphviz: Add native input....Andreas Enge
2023-02-19gnu: Use HTTPS package home pages wherever possible....Tobias Geerinckx-Rice
2023-02-20gnu: python-pygraphviz: Update to 1.10....Philippe SWARTVAGHER
2023-01-30gnu: texlive-fancyhdr: Use over deprecated texlive-latex-fancyhdr....Efraim Flashner
2023-01-30gnu: texlive-graphics: Use over deprecated texlive-latex-graphics....Efraim Flashner
2023-01-30Merge remote-tracking branch 'origin/master' into core-updates...Efraim Flashner
2022-12-13gnu: python-graphviz: Update to 0.20.1....Ricardo Wurmus
2022-11-20gnu: graphviz: Update to 7.0.1 and remove input labels....Maxim Cournoyer