diff --git a/fileio.c b/fileio.c
index ba0a1d0..03fc4be 100644
--- a/fileio.c
+++ b/fileio.c
@@ -2006,6 +2006,7 @@ int do_string(__G__ length, option) /* return PK-type error code */
unsigned comment_bytes_left;
unsigned int block_len;
int error=PK_OK;
+ unsigned int length2;
#ifdef AMIGA
char tmp_fnote[2 * AMIGA_FILENOTELEN]; /* extra room for squozen chars */
#endif
@@ -2292,8 +2293,12 @@ int do_string(__G__ length, option) /* return PK-type error code */
seek_zipf(__G__ G.cur_zipfile_bufstart - G.extra_bytes +
(G.inptr-G.inbuf) + length);
} else {
- if (readbuf(__G__ (char *)G.extra_field, length) == 0)
+ if ((length2 = readbuf(__G__ (char *)G.extra_field, length)) == 0)
return PK_EOF;
+ if(length2 < length) {
+ memset (__G__ (char *)G.extra_field+length2, 0 , length-length2);
+ length = length2;
+ }
/* Looks like here is where extra fields are read */
getZip64Data(__G__ G.extra_field, length);
#ifdef UNICODE_SUPPORT
=f72a1253a18798a25245b4124c1da35ed993e0d1'>refslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2021-05-09 | gnu: libcap: Update to 2.49....* gnu/packages/linux.scm (libcap-2.31): Rename to ...
(libcap): ... this: Update to 2.49.
[arguments]: Adjust substitution.
(libcap/next): Remove variable.
* gnu/packages/avahi.scm (avahi)[inputs]: Change from LIBCAP/NEXT to LIBCAP.
* gnu/packages/base.scm (coreutils)[inputs]: Likewise.
| Marius Bakke |
2020-10-13 | gnu: libcap: Make 'libcap/next' the default libcap....* gnu/packages/avahi.scm (avahi)[inputs]: Refer to LIBCAP-2.31 instead of LIBCAP.
* gnu/packages/base.scm (coreutils)[inputs]: Likewise.
* gnu/packages/linux.scm (libcap): Rename to ...
(libcap-2.31): ... this.
(libcap/next): Rename to ...
(libcap): ... this.
(libcap/next): Define as deprecated alias for LIBCAP.
(fakeroot)[inputs]: Change from LIBCAP/NEXT to LIBCAP.
* gnu/packages/ntp.scm (chrony, ntp)[inputs]: Likewise.
| Marius Bakke |
2020-03-18 | gnu: avahi: Update to 0.8....* gnu/packages/patches/avahi-CVE-2018-1000845.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/avahi.scm (avahi): Update to 0.8.
[source](patches): Remove obsolete patch.
[properties]: Remove.
[arguments]: Remove "--disable-qt3" from #:configure-flags. Add "--disable-qt5".
[inputs]: Add LIBEVENT. Sort lexicographically.
[native-inputs]: Remove INTLTOOL. Add GETTEXT-MINIMAL.
| Marius Bakke |
2020-03-18 | gnu: avahi: Do not build the static libraries....* gnu/packages/avahi.scm (avahi)[arguments]: Add "--disable-static" to
#:configure-flags.
| Marius Bakke |
2020-01-21 | Merge branch 'staging' into core-updates | Marius Bakke |
2020-01-19 | gnu: Use HTTPS for avahi.org everywhere....* gnu/packages/avahi.scm (avahi)[home-page]: Use HTTPS.
* gnu/services/avahi.scm (avahi-service): Likewise in docstring.
| Tobias Geerinckx-Rice |
2019-12-05 | gnu: avahi: Incorporate grafted changes....* gnu/packages/avahi.scm (avahi)[replacement]: Remove.
[source](patches): Add avahi-CVE-2018-1000845.patch.
[properties]: New field.
(avahi/fixed): Remove variable.
| Marius Bakke |
2019-10-23 | gnu: avahi: Don't use package/inherit....Thanks to Mark H Weaver <mhw@netris.org>.
* gnu/packages/avahi.scm (avahi): Use (package (inherit …)) instead of
package/inherit.
| Tobias Geerinckx-Rice |
2019-10-23 | gnu: avahi: Fix CVE-2018-1000845 and duplicate CVE-2017-6519....* gnu/packages/avahi.scm (avahi/fixed): New variable.
(avahi)[replacement]: Use it.
* gnu/packages/patches/avahi-CVE-2018-1000845.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
| Tobias Geerinckx-Rice |