diff --git a/extract.c b/extract.c
index a0a4929..9ef80b3 100644
--- a/extract.c
+++ b/extract.c
@@ -2214,6 +2214,7 @@ static int test_compr_eb(__G__ eb, eb_size, compr_offset, test_uc_ebdata)
ulg eb_ucsize;
uch *eb_ucptr;
int r;
+ ush method;
if (compr_offset < 4) /* field is not compressed: */
return PK_OK; /* do nothing and signal OK */
@@ -2223,6 +2224,12 @@ static int test_compr_eb(__G__ eb, eb_size, compr_offset, test_uc_ebdata)
eb_size <= (compr_offset + EB_CMPRHEADLEN)))
return IZ_EF_TRUNC; /* no compressed data! */
+ method = makeword(eb + (EB_HEADSIZE + compr_offset));
+ if ((method == STORED) && (eb_size != compr_offset + EB_CMPRHEADLEN + eb_ucsize))
+ return PK_ERR; /* compressed & uncompressed
+ * should match in STORED
+ * method */
+
if (
#ifdef INT_16BIT
(((ulg)(extent)eb_ucsize) != eb_ucsize) ||
/a>summaryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2021-07-07 | guix-install.sh: Prompt for configuring substitutes discovery....Also ensure prompt_yes_no always print the message with a trailing space,
which is more pleasing to the eye.
* etc/guix-daemon.conf.in <--discover=no>: New guix-daemon option.
* etc/guix-daemon.service.in: Likewise.
* etc/init.d/guix-daemon.in: Likewise.
* etc/openrc/guix-daemon.in: Likewise.
* etc/guix-install.sh (configure_substitute_discovery): New procedure.
(sys_enable_guix_daemon): Ask the user whether automatic substitute discovery
should be enabled. Set the '--discover' argument accordingly.
(prompt_yes_no): Add a trailing space to the message.
(sys_authorize_build_farms): Remove trailing space from the message argument.
* NEWS (Distribution): Add news.
| Maxim Cournoyer |
2021-06-29 | pack: Add support for the deb format....* .dir-locals.el (scheme-mode)[gexp->derivation]: Define indentation rule.
* guix/scripts/pack.scm (debian-archive): New procedure.
(%formats): Register the new deb format.
(show-formats): Add it to the usage string.
* tests/pack.scm (%ar-bootstrap): New variable.
(deb archive with symlinks): New test.
* doc/guix.texi (Invoking guix pack): Document it.
* NEWS: Add news entry.
| Maxim Cournoyer |
2021-05-10 | Update NEWS. | Maxim Cournoyer |
2021-05-10 | Update NEWS. | Leo Famulari |
2021-05-10 | Update NEWS. | Ludovic Courtès |
2021-05-04 | Update NEWS. | Ludovic Courtès |
2020-11-22 | Update NEWS. | Ludovic Courtès |
2020-11-13 | Update NEWS. | Ludovic Courtès |
2020-11-09 | Update NEWS. | Ludovic Courtès |
2020-11-07 | Update NEWS. | Mathieu Othacehe |
2020-11-07 | Update NEWS. | Ludovic Courtès |
2020-11-05 | Update NEWS. | Ludovic Courtès |
2020-04-15 | Update NEWS. | Ludovic Courtès |
2020-04-12 | Update NEWS. | Ludovic Courtès |
2020-04-09 | Update NEWS. | Ludovic Courtès |
2019-05-17 | Update NEWS. | Ludovic Courtès |
2019-05-16 | Update NEWS. | Ludovic Courtès |
2019-05-01 | Update NEWS. | Ludovic Courtès |
2019-04-29 | Update NEWS. | Ludovic Courtès |
2019-04-28 | Update NEWS. | Ludovic Courtès |