diff --git a/extract.c b/extract.c index a0a4929..9ef80b3 100644 --- a/extract.c +++ b/extract.c @@ -2214,6 +2214,7 @@ static int test_compr_eb(__G__ eb, eb_size, compr_offset, test_uc_ebdata) ulg eb_ucsize; uch *eb_ucptr; int r; + ush method; if (compr_offset < 4) /* field is not compressed: */ return PK_OK; /* do nothing and signal OK */ @@ -2223,6 +2224,12 @@ static int test_compr_eb(__G__ eb, eb_size, compr_offset, test_uc_ebdata) eb_size <= (compr_offset + EB_CMPRHEADLEN))) return IZ_EF_TRUNC; /* no compressed data! */ + method = makeword(eb + (EB_HEADSIZE + compr_offset)); + if ((method == STORED) && (eb_size != compr_offset + EB_CMPRHEADLEN + eb_ucsize)) + return PK_ERR; /* compressed & uncompressed + * should match in STORED + * method */ + if ( #ifdef INT_16BIT (((ulg)(extent)eb_ucsize) != eb_ucsize) || aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/sddm.scm
AgeCommit message (Expand)Author
2020-03-01services: set-xorg-configuration: handle slim and sddm...Jakub Kądziołka
2020-02-16doc: Fix typo....Efraim Flashner
2019-10-21services: sddm: Add description....Ludovic Courtès
2019-10-21services: sddm: Deprecate 'sddm-service' procedure....Ludovic Courtès
2019-10-21services: sddm: Add default configuration....Brendan Tildesley
2019-05-26services: sddm: Fix root login failure issue....Reza Alizadeh Majd
2019-04-11services: sddm: Switch back to using ‘startx’....frozenpigs
2019-03-25services: SDDM: Specify absolute path to the X server....Marius Bakke
2019-03-24services: sddm, slim, gdm: Take an <xorg-configuration> record....Ludovic Courtès
2016-12-21gnu: Fix typo in comment....John Darrington
2016-10-15gnu: services sddm Fix typo....John Darrington
2016-09-10system: Use 'file-append' to denote file names....Ludovic Courtès
2016-09-06services: Add sddm service....David Craven