Copied from Fedora.
http://pkgs.fedoraproject.org/cgit/unzip.git/plain/unzip-6.0-overflow-long-fsize.patch?id=d18f821e
diff --git a/list.c b/list.c
index f7359c3..4c3d703 100644
--- a/list.c
+++ b/list.c
@@ -97,7 +97,7 @@ int list_files(__G) /* return PK-type error code */
{
int do_this_file=FALSE, cfactor, error, error_in_archive=PK_COOL;
#ifndef WINDLL
- char sgn, cfactorstr[10];
+ char sgn, cfactorstr[13];
int longhdr=(uO.vflag>1);
#endif
int date_format;
@@ -339,7 +339,19 @@ int list_files(__G) /* return PK-type error code */
G.crec.compression_method == ENHDEFLATED) {
methbuf[5] = dtype[(G.crec.general_purpose_bit_flag>>1) & 3];
} else if (methnum >= NUM_METHODS) {
- sprintf(&methbuf[4], "%03u", G.crec.compression_method);
+ /* 2013-02-26 SMS.
+ * http://sourceforge.net/tracker/?func=detail
+ * &aid=2861648&group_id=118012&atid=679786
+ * Unexpectedly large compression methods overflow
+ * &methbuf[]. Use the old, three-digit decimal format
+ * for values which fit. Otherwise, sacrifice the
+ * colon, and use four-digit hexadecimal.
+ */
+ if (G.crec.compression_method <= 999) {
+ sprintf( &methbuf[ 4], "%03u", G.crec.compression_method);
+ } else {
+ sprintf( &methbuf[ 3], "%04X", G.crec.compression_method);
+ }
}
#if 0 /* GRR/Euro: add this? */
'/guix/log/gnu/packages/simulation.scm'>
log msg
author
committer
range
Age Commit message (Expand ) Author
2023-08-29 gnu: python-dolfin-adjoint: Fix build. ...* gnu/packages/simulation.scm (python-dolfin-adjoint): Fix build.
[arguments]: Disable failing test_read_checkpoint in 'check phase.
Remove broken 'sanity-check phase.
Signed-off-by: Andreas Enge <andreas@enge.fr>
Felix Gruber
2023-08-11 gnu: openfoam-org: Use 'git-fetch'. ...So far the source was taken from an auto-generated, unstable tarball at
github.com. This fixes that.
* gnu/packages/simulation.scm (openfoam-org)[source]: Switch to
'git-fetch'.
[arguments]: Add 'rename-self' phase.
Ludovic Courtès
2023-08-10 gnu: Add openfoam-com. ...* gnu/packages/simulation.scm (openfoam-com): New variable.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
reza
2023-08-10 gnu: Add openfoam-org. Deprecate openfoam. ...* gnu/packages/patches/openfoam-4.1-cleanup.patch: Delete file.
* gnu/local.mk: Remove it.
* gnu/packages/simulation.scm (openfoam-org): New variable.
(openfoam): Mark as deprecated.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
reza