Copied from Fedora. http://pkgs.fedoraproject.org/cgit/unzip.git/plain/unzip-6.0-overflow-long-fsize.patch?id=d18f821e diff --git a/list.c b/list.c index f7359c3..4c3d703 100644 --- a/list.c +++ b/list.c @@ -97,7 +97,7 @@ int list_files(__G) /* return PK-type error code */ { int do_this_file=FALSE, cfactor, error, error_in_archive=PK_COOL; #ifndef WINDLL - char sgn, cfactorstr[10]; + char sgn, cfactorstr[13]; int longhdr=(uO.vflag>1); #endif int date_format; @@ -339,7 +339,19 @@ int list_files(__G) /* return PK-type error code */ G.crec.compression_method == ENHDEFLATED) { methbuf[5] = dtype[(G.crec.general_purpose_bit_flag>>1) & 3]; } else if (methnum >= NUM_METHODS) { - sprintf(&methbuf[4], "%03u", G.crec.compression_method); + /* 2013-02-26 SMS. + * http://sourceforge.net/tracker/?func=detail + * &aid=2861648&group_id=118012&atid=679786 + * Unexpectedly large compression methods overflow + * &methbuf[]. Use the old, three-digit decimal format + * for values which fit. Otherwise, sacrifice the + * colon, and use four-digit hexadecimal. + */ + if (G.crec.compression_method <= 999) { + sprintf( &methbuf[ 4], "%03u", G.crec.compression_method); + } else { + sprintf( &methbuf[ 3], "%04X", G.crec.compression_method); + } } #if 0 /* GRR/Euro: add this? */ ype='hidden' name='id' value='122b3cd68dbc6c83de5357d4db4d82d2fd92d9b1'/>
path: root/tests/containers.scm
AgeCommit message (Expand)Author
2019-10-15tests: Skip container test when lacking kernel support....Ludovic Courtès
2019-09-18linux-container: 'eval/container' correctly passes -L and -C flags....Ludovic Courtès
2019-07-19linux-container: Add 'eval/container'....Ludovic Courtès
2019-04-02linux-container: Make the guest UID and GID a parameter....Ludovic Courtès
2017-05-31tests: Fix race condition in 'container-excursion*' test....Ludovic Courtès
2017-02-07linux-container: Add 'container-excursion*'....Ludovic Courtès
2016-11-13tests: Don't check file-systems in container tests....Andy Patterson
2016-11-10container: Pass a list of <file-system> objects as things to mount....Ludovic Courtès
2016-10-19container: Allow 'container-excursion' to the same namespaces....Ludovic Courtès
2016-06-25tests: Skip all the container tests when needed....Ludovic Courtès
2016-05-31container: Gracefully report mount errors in the child process....Ludovic Courtès
2016-04-03build: Add a Guile custom test driver using SRFI-64....Mathieu Lirzin