--- a/fileio.c 2014-12-05 05:06:05 -0600 +++ b/fileio.c 2017-11-14 01:06:28 -0600 @@ -1,5 +1,5 @@ /* - Copyright (c) 1990-2009 Info-ZIP. All rights reserved. + Copyright (c) 1990-2017 Info-ZIP. All rights reserved. See the accompanying file LICENSE, version 2009-Jan-02 or later (the contents of which are also included in unzip.h) for terms of use. @@ -1582,6 +1582,8 @@ int r = IZ_PW_ENTERED; char *m; char *prompt; + char *ep; + char *zp; #ifndef REENTRANT /* tell picky compilers to shut up about "unused variable" warnings */ @@ -1590,9 +1592,12 @@ if (*rcnt == 0) { /* First call for current entry */ *rcnt = 2; - if ((prompt = (char *)malloc(2*FILNAMSIZ + 15)) != (char *)NULL) { - sprintf(prompt, LoadFarString(PasswPrompt), - FnFilter1(zfn), FnFilter2(efn)); + zp = FnFilter1( zfn); + ep = FnFilter2( efn); + prompt = (char *)malloc( /* Slightly too long (2* "%s"). */ + sizeof( PasswPrompt)+ strlen( zp)+ strlen( ep)); + if (prompt != (char *)NULL) { + sprintf(prompt, LoadFarString(PasswPrompt), zp, ep); m = prompt; } else m = (char *)LoadFarString(PasswPrompt2); NEWS?id=2c229f1c10675b61e59482aef5eb8a655cd89d0d'>commitdiff
path: root/NEWS
AgeCommit message (Expand)Author
2020-04-15Update NEWS.Ludovic Courtès
2020-04-12Update NEWS.Ludovic Courtès
2020-04-09Update NEWS.Ludovic Courtès
2019-05-17Update NEWS.Ludovic Courtès
2019-05-16Update NEWS.Ludovic Courtès
2019-05-01Update NEWS.Ludovic Courtès
2019-04-29Update NEWS.Ludovic Courtès
2019-04-28Update NEWS.Ludovic Courtès
2018-12-05Update NEWS.Ludovic Courtès
2018-12-05Update NEWS.Ludovic Courtès
2018-11-23Update NEWS.Ludovic Courtès
2018-08-30Update NEWS.Ricardo Wurmus
2018-07-05Update NEWS.Ludovic Courtès
2018-07-05Update NEWS.Ludovic Courtès
2018-06-20Update NEWS.Ludovic Courtès
2018-05-29Update NEWS.Ricardo Wurmus
2018-05-20services: Add Enlightenment desktop service....Efraim Flashner
2018-05-08guix: Separate the package name and version with "@", not "-"....Chris Marusich
2017-12-06Update NEWS.Ludovic Courtès
2017-12-06Update NEWS.Ludovic Courtès
2017-12-05Update NEWS.Ludovic Courtès
2017-12-04Update NEWS.Ludovic Courtès