--- a/fileio.c 2014-12-05 05:06:05 -0600
+++ b/fileio.c 2017-11-14 01:06:28 -0600
@@ -1,5 +1,5 @@
/*
- Copyright (c) 1990-2009 Info-ZIP. All rights reserved.
+ Copyright (c) 1990-2017 Info-ZIP. All rights reserved.
See the accompanying file LICENSE, version 2009-Jan-02 or later
(the contents of which are also included in unzip.h) for terms of use.
@@ -1582,6 +1582,8 @@
int r = IZ_PW_ENTERED;
char *m;
char *prompt;
+ char *ep;
+ char *zp;
#ifndef REENTRANT
/* tell picky compilers to shut up about "unused variable" warnings */
@@ -1590,9 +1592,12 @@
if (*rcnt == 0) { /* First call for current entry */
*rcnt = 2;
- if ((prompt = (char *)malloc(2*FILNAMSIZ + 15)) != (char *)NULL) {
- sprintf(prompt, LoadFarString(PasswPrompt),
- FnFilter1(zfn), FnFilter2(efn));
+ zp = FnFilter1( zfn);
+ ep = FnFilter2( efn);
+ prompt = (char *)malloc( /* Slightly too long (2* "%s"). */
+ sizeof( PasswPrompt)+ strlen( zp)+ strlen( ep));
+ if (prompt != (char *)NULL) {
+ sprintf(prompt, LoadFarString(PasswPrompt), zp, ep);
m = prompt;
} else
m = (char *)LoadFarString(PasswPrompt2);
lloc.scm?id=3f62ddc0d5eebbff32bd05ba42148fdc3a6b02e3'>treecommitdiff
|
Age | Commit message (Expand) | Author |
2021-12-13 | gnu: Simplify package inputs....This commit was obtained by running:
./pre-inst-env guix style
without any additional argument.
| Ludovic Courtès |
2021-09-03 | gnu: jemalloc: --disable-initial-exec-tls...Disable the thread local storage model in jemalloc 5 to prevent
shared libraries linked to libjemalloc from crashing on dlopen().
https://github.com/jemalloc/jemalloc/issues/937
This bug affects both Java JNI and python libraries which link to
jemalloc 5, such as RocksDB, which will crash the program when loaded.
* gnu/packages/jemalloc.scm (jemalloc)[arguments]: Add --disable-initial-exec-tls
configure flag.
Co-authored-by: Ludovic Courtès <ludo@gnu.org>
| Ryan Sundberg |
2021-06-01 | gnu: jemalloc: Fix building on powerpc-linux....* gnu/packages/jemalloc.scm (jemalloc)[arguments]: Change configure-flags
so they are configurable per-architecture.
| Efraim Flashner |
2020-08-25 | gnu: jemalloc: Fix typo....* gnu/packages/jemalloc.scm (jemalloc)[arguments]: Check for the
'x86_64' architecture.
| Efraim Flashner |
2020-03-13 | gnu: jemalloc: Install scripts to separate output....* gnu/packages/jemalloc.scm (jemalloc)[outputs]: New field.
| Marius Bakke |