From 754137e70cf58a64ad524b704a86b651ba0cde07 Mon Sep 17 00:00:00 2001 From: Petr Stodulka Date: Wed, 14 Dec 2016 16:30:36 +0100 Subject: [PATCH] Fix CVE-2016-9844 (rhbz#1404283) Fixes buffer overflow in zipinfo in similar way like fix for CVE-2014-9913 provided by upstream. --- zipinfo.c | 14 +++++++++++++- 1 file changed, 13 insertions(+), 1 deletion(-) diff --git a/zipinfo.c b/zipinfo.c index c03620e..accca2a 100644 --- a/zipinfo.c +++ b/zipinfo.c @@ -1984,7 +1984,19 @@ static int zi_short(__G) /* return PK-type error code */ ush dnum=(ush)((G.crec.general_purpose_bit_flag>>1) & 3); methbuf[3] = dtype[dnum]; } else if (methnum >= NUM_METHODS) { /* unknown */ - sprintf(&methbuf[1], "%03u", G.crec.compression_method); + /* 2016-12-05 SMS. + * https://launchpad.net/bugs/1643750 + * Unexpectedly large compression methods overflow + * &methbuf[]. Use the old, three-digit decimal format + * for values which fit. Otherwise, sacrifice the "u", + * and use four-digit hexadecimal. + */ + if (G.crec.compression_method <= 999) { + sprintf( &methbuf[ 1], "%03u", G.crec.compression_method); + } else { + sprintf( &methbuf[ 0], "%04X", G.crec.compression_method); + } + } for (k = 0; k < 15; ++k) -- 2.5.5 container.scm?id=6fad3d5985f46ce19672c902fc93e0f91c3fb8f2'>commitdiff
path: root/gnu/build/linux-container.scm
AgeCommit message (Expand)Author
2022-09-24linux-container: Mark socket pair as SOCK_CLOEXEC....Ludovic Courtès
2022-09-20linux-container: 'container-excursion*' marks its FDs as FD_CLOEXEC....Ludovic Courtès
2022-05-01linux-container: Add #:child-is-pid1? parameter to 'call-with-container'....Ludovic Courtès
2022-05-01linux-container: Ensure signal-handling asyncs get a chance to run....Ludovic Courtès
2022-05-01linux-container: 'call-with-container' relays SIGTERM and SIGINT....Ludovic Courtès
2022-01-05linux-container: Handle CLONE_NEWCGROUP and use it by default....Ryan Sundberg
2020-12-06Revert "linux-container: Correct test for unprivileged user namespace support."...Marius Bakke
2020-12-03linux-container: Correct test for unprivileged user namespace support....Paul Garlick