Copied from Debian. From: Kamil Dudka Date: Mon, 14 Sep 2015 18:24:56 +0200 Subject: fix infinite loop when extracting empty bzip2 data Bug-Debian: https://bugs.debian.org/802160 Bug-RedHat: https://bugzilla.redhat.com/show_bug.cgi?id=1260944 Origin: other, https://bugzilla.redhat.com/attachment.cgi?id=1073339 --- extract.c | 6 ++++++ 1 file changed, 6 insertions(+) --- a/extract.c +++ b/extract.c @@ -2728,6 +2728,12 @@ int repeated_buf_err; bz_stream bstrm; + if (G.incnt <= 0 && G.csize <= 0L) { + /* avoid an infinite loop */ + Trace((stderr, "UZbunzip2() got empty input\n")); + return 2; + } + #if (defined(DLL) && !defined(NO_SLIDE_REDIR)) if (G.redirect_slide) wsize = G.redirect_size, redirSlide = G.redirect_buffer; elected='selected'>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/build-aux/check-final-inputs-self-contained.scm
AgeCommit message (Expand)Author
2018-12-04Remove most references to hydra.gnu.org....Ludovic Courtès
2018-03-25maint: Adjust 'check-final-inputs-self-contained' for glibc:static....Ludovic Courtès
2017-05-08maint: Use 'G_' in build-aux/ scripts....Ludovic Courtès
2016-12-18build: check-final-inputs-self-contained has an exception for 'bash:include'....Ludovic Courtès
2016-03-03build: Use (guix grafts) as needed....Ludovic Courtès
2015-05-10build: check-final-inputs-self-contained uses %HYDRA-SUPPORTED-SYSTEMS....Ludovic Courtès
2015-02-24build: Disable grafting in sanity checks....Ludovic Courtès
2015-01-14build: Use the canonical list of supported systems in 'assert-*'....Ludovic Courtès
2014-08-28gnu: Split (gnu packages base), adding (gnu packages commencement)....Ludovic Courtès
2014-06-18build: Add 'assert-final-inputs-self-contained' rule....Ludovic Courtès