Copied from Debian. From: Kamil Dudka Date: Mon, 14 Sep 2015 18:24:56 +0200 Subject: fix infinite loop when extracting empty bzip2 data Bug-Debian: https://bugs.debian.org/802160 Bug-RedHat: https://bugzilla.redhat.com/show_bug.cgi?id=1260944 Origin: other, https://bugzilla.redhat.com/attachment.cgi?id=1073339 --- extract.c | 6 ++++++ 1 file changed, 6 insertions(+) --- a/extract.c +++ b/extract.c @@ -2728,6 +2728,12 @@ int repeated_buf_err; bz_stream bstrm; + if (G.incnt <= 0 && G.csize <= 0L) { + /* avoid an infinite loop */ + Trace((stderr, "UZbunzip2() got empty input\n")); + return 2; + } + #if (defined(DLL) && !defined(NO_SLIDE_REDIR)) if (G.redirect_slide) wsize = G.redirect_size, redirSlide = G.redirect_buffer; cted='selected'>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mercury.scm
AgeCommit message (Expand)Author
2022-12-13gnu: mercury: Update to 22.01.4.jgart
2022-12-13gnu: mercury-minimal: Update to 22.01.4.jgart
2022-04-27gnu: mercury: Selectively import match-lambda from ice9 module.jgart
2022-03-29gnu: mercury: Remove trailing #T from phases and snippet.jgart
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2020-11-25gnu: mercury: Update to 20.06.1.Brett Gilio
2020-11-25gnu: mercury-minimal: Update to 20.06.1.Brett Gilio