Copied from Debian. From: Petr Stodulka Date: Mon, 14 Sep 2015 18:23:17 +0200 Subject: Upstream fix for heap overflow Bug-Debian: https://bugs.debian.org/802162 Bug-RedHat: https://bugzilla.redhat.com/show_bug.cgi?id=1260944 Origin: https://bugzilla.redhat.com/attachment.cgi?id=1073002 Forwarded: yes --- crypt.c | 12 +++++++++++- 1 file changed, 11 insertions(+), 1 deletion(-) --- a/crypt.c +++ b/crypt.c @@ -465,7 +465,17 @@ GLOBAL(pInfo->encrypted) = FALSE; defer_leftover_input(__G); for (n = 0; n < RAND_HEAD_LEN; n++) { - b = NEXTBYTE; + /* 2012-11-23 SMS. (OUSPG report.) + * Quit early if compressed size < HEAD_LEN. The resulting + * error message ("unable to get password") could be improved, + * but it's better than trying to read nonexistent data, and + * then continuing with a negative G.csize. (See + * fileio.c:readbyte()). + */ + if ((b = NEXTBYTE) == (ush)EOF) + { + return PK_ERR; + } h[n] = (uch)b; Trace((stdout, " (%02x)", h[n])); } f3085df1c64c23a00c8f0da'>refslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-16 21:48:31 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:41:53 +0300
commit60a989469743327e0f3085df1c64c23a00c8f0da (patch)
tree91045e1a9dcbeadb666f57ce5c7be6ae897feda6
parentc0865319a77cbbba17bc22beb002e601e80d0dd4 (diff)
downloadguix-60a989469743327e0f3085df1c64c23a00c8f0da.tar.gz
guix-60a989469743327e0f3085df1c64c23a00c8f0da.zip
gnu: Add rust-polars-0.37.
* gnu/packages/crates-io.scm (rust-polars-0.37): New variable. (rust-polars-0.17): Inherit from rust-polars-0.37. Change-Id: Ibd9371383eeed796d28e72f49a9208f7a4537722
-rw-r--r--gnu/packages/crates-io.scm42
1 files changed, 35 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ced43d4556..975b7dce27 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm