Copied from Debian. From: Petr Stodulka Date: Mon, 14 Sep 2015 18:23:17 +0200 Subject: Upstream fix for heap overflow Bug-Debian: https://bugs.debian.org/802162 Bug-RedHat: https://bugzilla.redhat.com/show_bug.cgi?id=1260944 Origin: https://bugzilla.redhat.com/attachment.cgi?id=1073002 Forwarded: yes --- crypt.c | 12 +++++++++++- 1 file changed, 11 insertions(+), 1 deletion(-) --- a/crypt.c +++ b/crypt.c @@ -465,7 +465,17 @@ GLOBAL(pInfo->encrypted) = FALSE; defer_leftover_input(__G); for (n = 0; n < RAND_HEAD_LEN; n++) { - b = NEXTBYTE; + /* 2012-11-23 SMS. (OUSPG report.) + * Quit early if compressed size < HEAD_LEN. The resulting + * error message ("unable to get password") could be improved, + * but it's better than trying to read nonexistent data, and + * then continuing with a negative G.csize. (See + * fileio.c:readbyte()). + */ + if ((b = NEXTBYTE) == (ush)EOF) + { + return PK_ERR; + } h[n] = (uch)b; Trace((stdout, " (%02x)", h[n])); } /'>summaryrefslogtreecommitdiff
path: root/tests/keys/ed25519-3.sec
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 18:55:54 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:16 +0800
commit96c1fe03a277ae0d14046b133e5d81b0702322d6 (patch)
tree3e704f75556abeb354ff1b28db44c0b529032e69 /tests/keys/ed25519-3.sec
parent43fdaf4a90feb7230ccf48e54f64690fad143424 (diff)
downloadguix-96c1fe03a277ae0d14046b133e5d81b0702322d6.tar.gz
guix-96c1fe03a277ae0d14046b133e5d81b0702322d6.zip
gnu: killbots: Update to 24.05.2.
* gnu/packages/kde-games.scm (killbots): Update to 24.05.2. [arguments]: Set #:qtbase to qtbase. [inputs]: Remove qtbase-5 and qtdeclarative-5; add qtdeclarative. Change-Id: I26dfd40cb3c8e15a1c3f2d27ab9bce31fe37ac76
Diffstat (limited to 'tests/keys/ed25519-3.sec')
0 files changed, 0 insertions, 0 deletions