Copied from Fedora. http://pkgs.fedoraproject.org/cgit/unzip.git/plain/unzip-6.0-overflow.patch?id=d18f821e diff --git a/extract.c b/extract.c index a0a4929..9ef80b3 100644 --- a/extract.c +++ b/extract.c @@ -2214,6 +2214,7 @@ static int test_compr_eb(__G__ eb, eb_size, compr_offset, test_uc_ebdata) ulg eb_ucsize; uch *eb_ucptr; int r; + ush method; if (compr_offset < 4) /* field is not compressed: */ return PK_OK; /* do nothing and signal OK */ @@ -2223,6 +2224,12 @@ static int test_compr_eb(__G__ eb, eb_size, compr_offset, test_uc_ebdata) eb_size <= (compr_offset + EB_CMPRHEADLEN))) return IZ_EF_TRUNC; /* no compressed data! */ + method = makeword(eb + (EB_HEADSIZE + compr_offset)); + if ((method == STORED) && (eb_size != compr_offset + EB_CMPRHEADLEN + eb_ucsize)) + return PK_ERR; /* compressed & uncompressed + * should match in STORED + * method */ + if ( #ifdef INT_16BIT (((ulg)(extent)eb_ucsize) != eb_ucsize) || 3e22258666f'>refslogtreecommitdiff
path: root/gnu/packages/graph.scm
AgeCommit message (Expand)Author
2023-04-24gnu: python-plotly-2.4.1: Patch for Python 3.10 changes....Ricardo Wurmus
2023-03-16gnu: python-plotly: Fix version detection....Sharlatan Hellseher
2023-03-13gnu: python-graph-tool: Update to 2.46....Ale Abdo
2023-02-19gnu: Use HTTPS package home pages wherever possible....Tobias Geerinckx-Rice
2023-02-10gnu: Add python-vtraag-louvain....Ricardo Wurmus
2023-01-27gnu: Remove python-louvain-0.7....Maxim Cournoyer
2023-01-27gnu: python-leidenalg: Update to 0.9.1....Maxim Cournoyer
2023-01-27gnu: python-igraph: Update to 0.10.4-0.b6ebd8e....Maxim Cournoyer
2023-01-27gnu: rw: Update to 0.9 and apply a patch to build with igraph >= 0.10....Maxim Cournoyer
2023-01-27gnu: igraph: Update to 0.10.4....Maxim Cournoyer
2023-01-07gnu: Use old setuptools in packages that relies on use_2to3 conversion....Marius Bakke
2022-12-11gnu: plfit: Update to 0.9.4....Tobias Geerinckx-Rice
2022-10-02gnu: python-louvain: Fix test....Greg Hogan