Copied from Fedora. http://pkgs.fedoraproject.org/cgit/unzip.git/plain/unzip-6.0-overflow.patch?id=d18f821e diff --git a/extract.c b/extract.c index a0a4929..9ef80b3 100644 --- a/extract.c +++ b/extract.c @@ -2214,6 +2214,7 @@ static int test_compr_eb(__G__ eb, eb_size, compr_offset, test_uc_ebdata) ulg eb_ucsize; uch *eb_ucptr; int r; + ush method; if (compr_offset < 4) /* field is not compressed: */ return PK_OK; /* do nothing and signal OK */ @@ -2223,6 +2224,12 @@ static int test_compr_eb(__G__ eb, eb_size, compr_offset, test_uc_ebdata) eb_size <= (compr_offset + EB_CMPRHEADLEN))) return IZ_EF_TRUNC; /* no compressed data! */ + method = makeword(eb + (EB_HEADSIZE + compr_offset)); + if ((method == STORED) && (eb_size != compr_offset + EB_CMPRHEADLEN + eb_ucsize)) + return PK_ERR; /* compressed & uncompressed + * should match in STORED + * method */ + if ( #ifdef INT_16BIT (((ulg)(extent)eb_ucsize) != eb_ucsize) || 06e76c463'>refslogtreecommitdiff
path: root/gnu/packages/fpga.scm
AgeCommit message (Expand)Author
2022-11-03gnu: nvc: Update to 1.7.2....* gnu/packages/fpga.scm (nvc): Update to 1.7.2. [inputs]: Add elfutils. [home-page]: Modify. Danny Milosavljevic
2022-10-11gnu: gtkwave: Update to 3.3.113....* gnu/packages/fpga.scm (gtkwave): Update to 3.3.113. [inputs]: Use new style. [arguments]: Use gexp. Signed-off-by: Ludovic Courtès <ludo@gnu.org> jgart
2022-09-16gnu: Add openfpgaloader....* gnu/packages/fpga.scm (openfpgaloader): New variable. Danny Milosavljevic
2022-09-02gnu: Add fftgen....* gnu/packages/fpga.scm (fftgen): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Gabriel Wicki
2022-08-17gnu: icestorm: Update to 0.0-4.2bc5417....* gnu/packages/fpga.scm (icestorm): Update to commit 2bc541743ada3542c6da36a50e66303b9cbd2059. 宋文武
2022-03-31gnu: iverilog: Add zlib dependency for LXT dump file format support....* gnu/packages/fpga.scm (iverilog)[native-inputs]: Add zlib. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Christian Gelinek
2022-01-14gnu: iverilog: Update to 11.0....* gnu/packages/fpga.scm (iverilog): Update to 11.0. [arguments]: Add make-flags. Danny Milosavljevic
2021-12-29gnu: python-myhdl: Fix trailing whitespace in description....* gnu/packages/fpga.scm (python-myhdl)[description]: Fix trailing whitespace. Vagrant Cascadian