From: sms Subject: Fix CVE-2014-8141: out-of-bounds read issues in getZip64Data() Bug-Debian: http://bugs.debian.org/773722 --- a/fileio.c +++ b/fileio.c @@ -176,6 +176,8 @@ #endif static ZCONST char Far ExtraFieldTooLong[] = "warning: extra field too long (%d). Ignoring...\n"; +static ZCONST char Far ExtraFieldCorrupt[] = + "warning: extra field (type: 0x%04x) corrupt. Continuing...\n"; #ifdef WINDLL static ZCONST char Far DiskFullQuery[] = @@ -2295,7 +2297,12 @@ if (readbuf(__G__ (char *)G.extra_field, length) == 0) return PK_EOF; /* Looks like here is where extra fields are read */ - getZip64Data(__G__ G.extra_field, length); + if (getZip64Data(__G__ G.extra_field, length) != PK_COOL) + { + Info(slide, 0x401, ((char *)slide, + LoadFarString( ExtraFieldCorrupt), EF_PKSZ64)); + error = PK_WARN; + } #ifdef UNICODE_SUPPORT G.unipath_filename = NULL
aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThiago Jung Bauermann via Guix-patches via <guix-patches@gnu.org>2021-09-16 02:18:16 -0300
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-16 09:49:31 +0200
commitb3ee04cde70579f84061342d62d86fcc2093dd6c (patch)
tree19dd44245ea2b9a153c292bfc636515aa803f547 /Makefile.am
parent35848d2c2ed9263a4c15f5358fcb4ec26db8d18a (diff)
downloadguix-b3ee04cde70579f84061342d62d86fcc2093