From: sms Subject: Fix CVE-2014-8140: out-of-bounds write issue in test_compr_eb() Bug-Debian: http://bugs.debian.org/773722 --- a/extract.c +++ b/extract.c @@ -2234,10 +2234,17 @@ if (compr_offset < 4) /* field is not compressed: */ return PK_OK; /* do nothing and signal OK */ + /* Return no/bad-data error status if any problem is found: + * 1. eb_size is too small to hold the uncompressed size + * (eb_ucsize). (Else extract eb_ucsize.) + * 2. eb_ucsize is zero (invalid). 2014-12-04 SMS. + * 3. eb_ucsize is positive, but eb_size is too small to hold + * the compressed data header. + */ if ((eb_size < (EB_UCSIZE_P + 4)) || - ((eb_ucsize = makelong(eb+(EB_HEADSIZE+EB_UCSIZE_P))) > 0L && - eb_size <= (compr_offset + EB_CMPRHEADLEN))) - return IZ_EF_TRUNC; /* no compressed data! */ + ((eb_ucsize = makelong( eb+ (EB_HEADSIZE+ EB_UCSIZE_P))) == 0L) || + ((eb_ucsize > 0L) && (eb_size <= (compr_offset + EB_CMPRHEADLEN)))) + return IZ_EF_TRUNC; /* no/bad compressed data! */ if ( #ifdef INT_16BIT e' href='/guix/log/gnu/packages/gnupg.scm'>logtreecommitdiff
path: root/gnu/packages/gnupg.scm
AgeCommit message (Expand)Author
2022-11-22gnu: gpgme: Add 1.18.0....* gnu/packages/gnupg.scm (gpgme-1.18, qgpgme-1.18): New variables. Marius Bakke
2022-10-30gnu: jetring: Update to 0.31....* gnu/packages/gnupg.scm (jetring): Update to 0.31. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice
2022-10-23gnu: pinentry-tty: Update to 1.2.1....* gnu/packages/gnupg.scm (pinentry-tty): Update to 1.2.1. Tobias Geerinckx-Rice
2022-10-16gnu: libksba: Graft to 1.6.2 [fixes CVE-2022-3515]....* gnu/packages/gnupg.scm (libksba/fixed): New variable. (libksba): Use it as grafted replacement. Tobias Geerinckx-Rice
2022-08-29gnu: gnupg: Use mirror URL....In commit 38747a27f36dbaadadb1399ec085d88e48c97555, the package switched from a mirror:// URL to a ftp:// URL, but there doesn't appear to have been any particular reason for that. * gnu/packages/gnupg.scm (gnupg)[source]{uri}: Use a mirror:// again. Signed-off-by: Marius Bakke <marius@gnu.org> Maxime Devos
2022-08-09gnu: gnupg: Patch CVE-2022-34903....* gnu/packages/gnupg.scm (gnupg)[replacement]: New field. (gnupg/replacement): New variable. * gnu/packages/patches/gnupg-CVE-2022-34903.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Efraim Flashner
2022-05-29gnu: pgpdump: Update to 0.35....* gnu/packages/gnupg.scm (pgpdump): Update to 0.35. Tobias Geerinckx-Rice
2022-05-31gnu: pius: Update to 3.0.0....* gnu/packages/gnupg.scm (pius): Update to 3.0.0. [arguments]: Delete tests? and python arguments. [phases]{set-gpg-file-name}: Streamline. [description]: Spell key signing as two words. Mark commands with Texinfo markup. Maxim Cournoyer
2022-05-31gnu: Remove python2-pygpgme....* gnu/packages/gnupg.scm (python2-pygpgme): Delete variable. Maxim Cournoyer
2022-05-31gnu: Remove python2-gpg....* gnu/packages/gnupg.scm (python2-gpg): Delete variable. Maxim Cournoyer